Page MenuHome

openexr bug
Closed, ResolvedPublic

Description

System Information
win7 64bit, GTX650ti

Blender Version
Broken: 2.75a
Worked: 2.74

Short description of error
I used file output node set with openexr file type to output render layers and render passes . When I wanted to use these openexr file to composite, I found the image input node only showed one render layer.

Exact steps for others to reproduce the error
I had create a file named "bug", you can use this one to create a openexr file. I also created a file named "bug_1" with openexr file.


1, open the bug_1 file, then use view node to check each output node of the image node. Only one render layer can show up and work. If open the bug_1 file with 2.74, every output node of the image node works.

Event Timeline

S S (b1657022405) updated the task description. (Show Details)
S S (b1657022405) raised the priority of this task from to Needs Triage by Developer.
S S (b1657022405) set Type to Bug.
Bastien Montagne (mont29) closed this task as Resolved.Aug 18 2015, 2:50 PM
Bastien Montagne (mont29) claimed this task.

Looks like this has been fixed already, please check with the latest build from our buildbot.

S S (b1657022405) reopened this task as Open.EditedAug 19 2015, 2:32 PM

I just test with 2.75-5668fc0, and the bug still exists.

Cannot reproduce here. Please attach here also the .exr file.

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.Aug 19 2015, 3:34 PM

here is the exr file :

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Confirmed, Medium.Aug 20 2015, 5:06 PM

Oh, OK, sorry, it’s me who did not understood correctly the issue…

Can confirm something is wrong here, either on writing or reading side, will check.

Caused by rB479b6696, which removed iuser->pass index, leading to only select passes based on their view and type. This may work with pure-render result, but certainly not with random composite OpenEXR images. Thinks you need to re-introduce pass index here… @Sergey Sharybin (sergey) may also have some ideas?

Bastien Montagne (mont29) raised the priority of this task from Confirmed, Medium to Confirmed, High.EditedAug 20 2015, 8:17 PM

Setting to high because this should really be fixed before 2.76 imho.

*sigh* yes I think pass index will have to be back