Page MenuHome

Viewport not entering rendered shading
Closed, InvalidPublic

Description

System Information
Kubuntu version 4.13.2
~$ lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.5 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 6 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation H77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M] (rev a1)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
02:00.1 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
03:00.0 USB controller: Texas Instruments TUSB73x0 SuperSpeed USB 3.0 xHCI Host Controller (rev 02)
04:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
05:00.0 Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 08)
~$ lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 8
On-line CPU(s) list: 0-7
Thread(s) per core: 2
Core(s) per socket: 4
Socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 58
Stepping: 9
CPU MHz: 1600.000
BogoMIPS: 6185.92
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 256K
L3 cache: 8192K

NUMA node0 CPU(s): 0-7

total       used       free     shared    buffers     cached

Mem: 8060944 7607892 453052 198716 152096 3222372
-/+ buffers/cache: 4233424 3827520
Swap: 15625212 112 15625100

Blender Version
Broken: 2.75
Worked: 2.74

Short description of error
Blender runs normally but in the viewport, when rendered view is turned on, blender tells me it is sampling, but I do not see any image or view. I do see the grey squares that normally indicate transparency, but that is all. Sampling finishes normally, and nothing changes.

Exact steps for others to reproduce the error
Simply startup blender in the basic scene (cube lamp and camera) change to cycles and change to viewport shading.

Details

Type
Bug

Event Timeline

Joseph Seamons (Blenderfire) updated the task description. (Show Details)
Joseph Seamons (Blenderfire) raised the priority of this task from to Needs Triage by Developer.

what is your blender hash number? I think it's already fixed in here 25bb5cb. I can't recreate this.

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.Aug 24 2015, 10:07 AM

Several questions:

  • Does this happen with latest builds from builder.blender.org?
  • Does this happen with Blender Internal rendering?
  • Does loading factory defaults change anything?
  • Does this happen when running blender-softwaregl?

One more thing, make sure you don't have viewport render pause enabled (button with pause icon in the viewport header).

Bastien Montagne (mont29) claimed this task.

No news since one week…