Page MenuHome

Cycles Standalone CUDA rendering renders black image
Closed, ResolvedPublic

Description

System Information
Windows 10 , Nvidia GT 740 graphic card, AMD FX processor , 8 GB RAM

Blender Version
NA

Short description of error
Cycles Standalone writes black image when rendered with CUDA.

Exact steps for others to reproduce the error
Use any XML scene file to render. Render with " device cpu" it will render and save jpeg with correct output. If you render with " device cuda" rendering will be fine , the live render output window will show correct rendering. But the image file written after completion of process, will be black image.

Event Timeline

dsman (dsman) assigned this task to Thomas Dinges (dingto).
dsman (dsman) raised the priority of this task from to 90.
dsman (dsman) updated the task description. (Show Details)
dsman (dsman) added a project: Cycles.
dsman (dsman) edited a custom field.
dsman (dsman) added a subscriber: dsman (dsman).
Sergey Sharybin (sergey) lowered the priority of this task from 90 to Normal.Sep 1 2015, 12:24 PM

which device do you use?
@Sergey Sharybin (sergey), I got a similar problem "in a rare case, where I tested on dual GTX Titan X, CUDA 7 SDK, 1 of the Titans is always rendering black image, the other is fine (this is ONLY in experimental model)

Seems to be working now. I created fresh build after September 08 commit (on cycles repository ) and it was working. Don't know what was the issue.

Brecht Van Lommel (brecht) changed the task status from Unknown Status to Resolved.Oct 25 2015, 11:40 AM

Ok, thanks, closing the report then.