Page MenuHome

light.type appears to not do anything when set in engine
Closed, ArchivedPublic

Description

when setting a lamp.type value

the manual says, accepts SPOT , SUN and NORMAL

however actually it accepts 0, 1, or 2

and setting these values appears to do nothing.

2.75a

in this file, each lamp hook has a property Type, that is a integer, 0 , 1 , or 2,

these should set the lamps type to spot, sun and point, but do nothing.

Details

Type
Bug

Event Timeline

Porteries Tristan (panzergame) raised the priority of this task from Normal to Confirmed, Medium.

@Jacob Merrill (blueprintrandom): You can't modify an object attribut by creating a similar object property and less if it named "Type" instead of "type". But if you test with KX_LightObject.type the effect is the same because shader are compiled for only one type of lamp.
@Antony Riakiotakis (psy-fi): In the viewport refractor we will still need to recompile the shader to allow modify a lamp type ?

Aaron Carlisle (Blendify) closed this task as Archived.

This task is being closed because the BGE has been removed in Blender 2.8.