Page MenuHome

Blender fbx does not export normals correctly for blendshapes
Confirmed, NormalPublicTO DO

Description

System Information
Win7 x64

Blender Version
Broken: 2.75
Worked: (optional)

Short description of error
When exporting a model that has blendshapes as fbx, the resulting model does not get the correct normals, it only seems to get the normals from the base shape rather than the normals it should get when the blendshape is applied.

Exact steps for others to reproduce the error
For more details and example photos please see here http://forum.unity3d.com/threads/uma-unity-multipurpose-avatar-on-the-asset-store.219175/page-67#post-2281165

Event Timeline

Sergey Sharybin (sergey) lowered the priority of this task from 90 to 30.Sep 5 2015, 5:05 PM

Please always attach small /blend file which demonstrated the issue.

And please stop linking to forums posts in reports! We need all relevant info here, not on some random remote place that may go offline or break links at any time!

Bastien Montagne (mont29) changed the task status from Unknown Status to Unknown Status.Sep 7 2015, 2:30 PM

Actually, this is not a bug, but rather a TODO (we have no way to access normals from a shape-key currently in Blender, will add that but this does not qualifies as a bug - and cannot be added to master that close of a release).

This problem still seems to be present in 2.78c. Normals of blend shapes still are the ones of the base shape. I tried both in binary and ascii.

Bastien Montagne (mont29) changed the task status from Unknown Status to Unknown Status.Jun 15 2017, 2:51 PM
Bastien Montagne (mont29) raised the priority of this task from 30 to 50.
Bastien Montagne (mont29) edited a custom field.

Yeah… actually, correct commit now Blender-side is rBcdd727b7ceab5772503b702322e93620b7df651b (seems like there were some history rewriting :| ).

Re-opened and moved as TODO task.