Page MenuHome

2 GPU cards (GTX 980 and GTX 980 TI) cause crashes
Closed, ArchivedPublic

Description

System Information
Operating system and graphics Card
Windows 7 Home Premium 64 bit
Nvidia GTX 980 and GTX 980 TI
i7-2600, 16 GB RAM

Blender Version
Broken: 2.75a c7589e
Worked: (optional)

Short description of error
Using Cycles (CUDA), scene: 270.096 faces,, 2 GPU's found and used by Belnder System.
Animation starts to render, but after 8 to 10 frames, blender crahses.
Sometimes with a blue screen, sometimes just comes a TDR warning by Nvidia.
I have raised the TDR Delay in the registry up to 8 sec. But still the same: Crash after 10 Frames.

On my other machine (Windows 7 Professional, i7-4960X, 64 GB RAM) with Nvidia GTX 780 and GTX 580 there are no such problems.

Exact steps for others to reproduce the error
Please see above

Details

Type
Bug

Event Timeline

Martin Harth (mhcall) set Type to Bug.
Martin Harth (mhcall) created this task.
Martin Harth (mhcall) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Clearly some driver issue/bug…
Please:

  • Ensure both your OS and drivers are fully up-to-date.
  • Attach as text file here the report generated by Help -> System Info (¡¡¡DO NOT paste it directly in comment!!!).
  • Launch Blender from the command line with -d option and attach as text file here any error printed out in the console (¡¡¡DO NOT paste it directly in comment!!!).

Thank you for your fast reply, Bastien!
I have updated both graphic Drivers, and currently I am running a new test along your advice (command line).
As soon as I have a result, I will post this here.

After some more tests, the system either crashes (blue screen) or creates a failure message (Nvidia warning).
Windows OS and both graphic cards have been updated before.

Interesting to me that with only one card used in the blender preferences, the machine works seamlessly flowing.
Also I should say that the first 2 weeks after installing both cards,, there were no problems.. they just started today).

I didn't find a 'system-info.txt' on the machine.
However, I copied the log file created by the command line startup and attached i.t here.
There seems to be a Python issue. But I have no idea whether this is connected to the Problem or not...

Thanks a lot for any help!
Martin

Hi, create system-info from Blender Help menu, change to Blender text editor.
Open the file in the pulldown menu near +New, Open

Cheers, mib

Hi Wolfgang, here it comes... and thank you for advising of how to do!

The problem is still the same... I can't create a dump, because the blue Screen kills everything.

Kind regards
Martin

Well, blue screen & co are really a driver issue, no app shall be able to produce that kind of crash! Maybe some conflict or race condition between the two cards?

And 353 is not the latest drivers, NVidia's site lists 355.82 as latest release…

Also, did not saw that, but you are still using official 2.75a (rBc27589e19fc0), please try the latest build from our buildbot.

Sergey Sharybin (sergey) closed this task as Archived.
Sergey Sharybin (sergey) claimed this task.

As i understand, so far it was all about 2.75a release which means the only thing which might have been changed is your operation system or driver (via some windows update or so for example). That is the only way to explain reason of your setup working for 2 weeks and then stopped working for the same exact version of blender.

Even if there's a race condition between cards it happens in driver, not in blender. Blender itself does not control any hardware.

So thanks for the report, but we can't fix issues in closed source OS and drivers.

Hi Sergey,

Well noted, and I fully agree by simple logics.
Many thanks to all of you for trying to help!
However, I have installed a Windows 10, and I have still the same Problem.
So this might be 'just' a Driver Problem in the very end.
I will try some further steps (for example a third 'raw' machine with a single 980 Ti)... or even go back to earlier dirvers...

Kind regards
Martin

Windows 10 might have even more issues than Windows 7 due to it's policy of downloading drivers from windows update and overriding drivers which you manually installed. Higher windows version doesn't really mean higher quality, unfortunately :(

What you can do in order to test if it's indeed OS or driver issue is to go ahead and boot into Ubuntu Livecd and try rendering from there. Think it should be possible to install all required drivers in a livecd mode.

Hi Sergey,

I agree about your opinion reagrding Windows 10 and so on... (as Windows goes, I still prefer the 7 Version 64)
Ubuntu... ok, I was thinking already many times to install this as a second boot Option, but honestly, I have no experience with it. I "have" to mainly use Windows, since many other applications are made for it, such as Afetr Effects, Cubase, and so on).

But:
In the meantime, I have tested several completely different blender Scenes on the Windows 10 pc.
Example 1: 110.592 molecular particles but only with 37.473 "real" faces, but with tons of texture mapping) are seamlessly rendering down all Frames without any hanging, each Frame abbout 8 minutes.
Example 2: 15.600 cubes, no texture mapping, and it continously crashes after a few Frames.

Due to my simple logics, this could sound a litlte bit as if it depends more on the blender Scenes / Setup / configuration, rather than on the GPU Driver issues. But I am not a pro in this matter and maybe I am wrong... ?

What you guess?

I forgot this:

Example 3: 634.525 Faces, lots of huge texture maps (~ 4K), softbody collision, Rendering down all Frames without hanging, each Frame about 8 minutes. This just for additional Information.