Page MenuHome

Dyntopo color bug
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: (all)
Worked: (none)

Short description of error






Exact steps for others to reproduce the error
open blender (maybe with standart cube)
go to sculpt mode and repeat my test

Details

Type
Bug

Event Timeline

Alexey (Inwader77) raised the priority of this task from to Needs Triage by Developer.
Alexey (Inwader77) updated the task description. (Show Details)
Alexey (Inwader77) set Type to Bug.
Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Oct 16 2015, 2:15 PM

Confirmed, @Antony Riakiotakis (psy-fi), maybe you have some insight here?

The limitation has always been there. There is a checkbox in the Options tab of the tools panel to show diffuse color while dyntopo is active.

But, the color not updating afterwards does look like a bug.

Edit: I've just tested the switch to multitexture with "show diffuse color" on, the object stays consistently showing the material color, nothing like your screenshots show. Changing the shading mode to textured makes the object look grey, but color returns if you switch back.

The limitation has always been there. There is a checkbox in the Options tab of the tools panel to show diffuse color while dyntopo is active.


But, the color not updating afterwards does look like a bug.
Edit: I've just tested the switch to multitexture with "show diffuse color" on, the object stays consistently showing the material color, nothing like your screenshots show. Changing the shading mode to textured makes the object look grey, but color returns if you switch back.

Yes, all proper, but if we switch on dyntopo, and then switch off - we will loose color

Yes, all proper, but if we switch on dyntopo, and then switch off - we will loose color

Ehm, have you even tried the option? I just did, no amount of switching dyntopo on/off makes it lose the color.

I'm not saying the fiddling with multitexture/textured shading is not a bug, although I have no idea why you would want to do that for sculpting.
All I'm saying is the problem was already addressed by having the option to show diffuse color in sculpt mode some time ago. If you want the option to be always on by default and no checkbox to activate/de-activate it, that's another thing, but I wouldn't call it a bug.

This comment was removed by Alexey (Inwader77).

Here's what your removed comment said:

1. Select solid shading mode.

2)go to sculpt mode
3)add material, set any color - see proper color
4)switch on dyntopo - color loose(all OK because"show diffuse color" switch off)
5)switch off dyntopo - we have not color of material, bug(because dyntopo switched off)

Ok, I give up. Material color has been disappearing like you mentioned at least since Dyntopo was developed IIRC, that's why the option to show diffuse color was developed in the first place. But, if you refuse to use it and insist in having a problem with it, there's nothing I can do. I hope a developer has the time to fix the messy situation with diffuse color in Sculpt mode.

Sergey Sharybin (sergey) closed this task as Archived.Feb 2 2016, 3:12 PM
Sergey Sharybin (sergey) claimed this task.

Dyntopo is using some special tricks to draw things and currently indeed requires having "Show Diffuse Color" enabled in the settings to work same as non-dyntopo.

In fact, it's more a non-dyntopo issue which doesn't respect that setting unless Mask brush is used.

Thanks for the report, but it's just a nice improvement project for the new viewport.