Page MenuHome

Drivers do not work in node groups.
Closed, ArchivedPublic

Description

System Information
Windows 7 64 bit with 64 bit Blender

Blender Version
Broken: 2.76.2 fbca69c

Short description of error
Drivers do not work, when they are inside a node group.
(Didn't test it outside the compositor.)

Exact steps for others to reproduce the error


The value node on the top left (labeled "#frame") has a driver which takes the current frame number.
The group node below contains a value node also has a driver, and should output the current frame number. But this does NOT work.

So you can see it, if you render, the output of the group node is displayed on the left; the output of the (ungrouped) value node is displayed on the right.

Event Timeline

Philip Holzmann (Foaly) raised the priority of this task from to Needs Triage by Developer.
Philip Holzmann (Foaly) updated the task description. (Show Details)
Philip Holzmann (Foaly) set Type to Bug.

This is something which can't really work in the old depsgraph but something i would expect to work in the new one. Need to have some closer look tho.

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Oct 27 2015, 7:23 PM

Hi,

the problem still exists!
I have the x value of a blur node driven by the Z location of the default cube. This works.
But if I put the blur node into a group then it does not work anymore, the x value is always zero.

My Blender version is 2.76b, Date 2015-11-03- 10:56, Hash f337fea.
I use the Windows 64 bit version

Best regards,

Mr. Burns

Mr. Burns (mrburns) added a comment.EditedJan 20 2016, 11:58 AM

Hi,

I also tested with version 2.76 Date 2016-01-20 00:43 hash bda0820, but still the same. The Z location of the cube is 2.15.
The blur node inside group does not update the x value. It shows 3.
The blur node out of group does it correctly. It shows 2.
(both use same driver)

If this doesn't work after switching to the new dependency graph, then please make a new bug report including all the details and .blend file demonstrating the problem.

@Mr. Burns (mrburns), you need to explicitly enable the new dependency graph by launching Blender from the command line with the --enable-new-depsgraph argument.

Lukas Remis (alienpriv) reopened this task as Open.EditedJun 17 2018, 9:42 PM

This bug is still present in 2.79b (Mac version)

.
Attaching test file. I try to drive some values inside a group with the input value from the group node.

Tried starting Blender with --enable-new-depsgraph - still drivers do not work in node groups.

Sergey Sharybin (sergey) lowered the priority of this task from Confirmed, Medium to Needs Information from User.Oct 29 2018, 4:36 PM

Please make a simple file where it's clear which exact drivers do not work. If it's possible top reproduce with one driver, that'd be way more clear to understand desired behavior.

In this example some of the drivers are actually set to constant values, and some other drivers are trying to drive nodes of same node tree. Note that this should probably work, but chained drivers are not yet supported (as in, node_a drivers node_b and node_b drives node_c of the same tree).

Philipp Oeser (lichtwerk) closed this task as Archived.Nov 9 2018, 11:12 AM

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.