Page MenuHome

Volume Emission doesn't render when background is transparent
Closed, ArchivedPublic

Description

System Information
Mac OS X 10.6.8
NVIDIA GeForce 320M

  • and -

OS X 10.10.2
Intel Iris Pro 1536 MB

Blender Version
Broken: 2.76 48f7dd6
Worked: unknown

Short description of error
Plugging an Emission Shader into the Volume output has no effect if the scene's background is transparent. The object with the volume emission material renders as transparent, so you see nothing but an empty transparent (checkered) background.

It does display as expected in the Material Preview and in Viewport Render mode.

If you also plug a Mix Shader into the Surface output, and mix a Diffuse (for example) and a Transparent Shader together, emission will be visible (if mixed somewhere between 0 and 1), but only to a limited degree. And once again, the rendered result differs from the Material Preview and Viewport Render.

Exact steps for others to reproduce the error

  1. Add an object and give it a material with no surface shader, only an Emission Shader plugged into the Volume output.
  2. Do a test render to verify that it is showing up.
  3. Enable the Film > Transparent option in the Render Context.
  4. Render again and find that the object has become invisible.

Details

Type
Bug

Event Timeline

Seth L. (quantumanomaly) set Type to Bug.
Seth L. (quantumanomaly) created this task.
Seth L. (quantumanomaly) raised the priority of this task from to Needs Triage by Developer.
Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Add a little volume absorption to the emission to solve the issue. In reality it would be very unusual to have volumes that emit light but not block any light at all.

See e.g. T41482, T42130, T41844 for more info, not considered a bug at the moment. If you save the file to EXR or composite it over something else in the compositor the emission will be there. But if you save it to e.g. PNG or display it in the image editor the emission will not show, because those image representations do not support this type of emission full transparency.