Page MenuHome

Compiling Blender with closed panels in Factory settings
Closed, InvalidPublic

Description

System Information
Operating system and graphics card

Windows 7 64 Bit
Nvidia 760 gtx

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

Short description of error

Compiling Blender under Windows 7 with Cmake 3.3.0 and Visual Studio

Blender uses a startup.blend in the source code to create the factory settings. Theming settings like width and what tab is active gets recognized. Panel status open/closed not.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

I am not sure if this issue qualifies as a bug report since it is more relevant to developers. Users will not stumble across it directly. I nevertheless try it. With the hope that i get at least a hint.

One of the UI problems is the visual noise. Too much open at once.

Blender uses a startup.blend in the release/datafiles folder to create the factory settings. What is stored in this startup.blend will be the factory settings then.

When i use Blender as a user, and close all panels, like the ones in the Properties editor, and save the startup file, and when i restart Blender then, then those panels stays closed. So far so good. That's what the user can do. And here it works as intended. So the needed values are for sure available.

When i grab this created startup.blend file then, and use it to recompile Blender, and when i open the fresh compiled Blender version then, then the panels are as they were in the previous Blender factory settings. Open.

I would like to change this factory settings though. So that the factory settings already contains the closed panels.

All other UI settings gets compiled. Width of the panels, arrangement, etc. . But the panels stays open.

I cannot test if it works on Linux since i don't have Linux. Does it work on Linux? Is it a Windows 7 only problem? A settings problem with VS or CMake? Or is it a bug?

The first image shows the open tabs from the factory settings. The second image shows the closed tabs as i would love to have them in the factory settings too.

Kind regards

Reiner

Details

Type
Bug

Event Timeline

Reiner Prokein (tiles) updated the task description. (Show Details)
Reiner Prokein (tiles) raised the priority of this task from to Needs Triage by Developer.
Reiner Prokein (tiles) set Type to Bug.
Julian Eisel (Severin) closed this task as Invalid.EditedDec 14 2015, 1:27 PM
Julian Eisel (Severin) claimed this task.

No, this isn't a bug (well... for now).
The opened/closed state of a panel is read from .blends, but it's default state is defined when the panel is registered. See our API docs.

One more hint since I've seen your Bforartists tracker: The startup.blend in release/datafiles is not the only place to initialize factory/default settings. Git's method to handle binary files (such as .blends) is really memory hungry, so we try to avoid having to update such files for most cases.