Page MenuHome

Sculpt error: hide border
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: (all)
Worked: (none)

Short description of error




Exact steps for others to reproduce the error

open - all properly
select any other shading mode - we will not see hidden area

Event Timeline

Alexey (Inwader77) updated the task description. (Show Details)
Alexey (Inwader77) raised the priority of this task from to Needs Triage.
Alexey (Inwader77) set Type to Bug.

I can confirm it but the hidden part stay hidden if you turn Dyntopo on.

Alexey (Inwader77) added a comment.EditedJan 22 2016, 12:11 AM

yes, if we switch on dyntopo - we will see hidden area. But if we switch on, select rendered shading mode - we will have this bug again

@Alexey (Inwader77) please upload simple .blend files, there is absolutely no need for an 8Mb one to demonstrate this bug!

Bastien Montagne (mont29) triaged this task as Confirmed priority.Jan 22 2016, 3:49 PM

Mike, maybe you know 'off hand' where the issue could be? ;)

@Alexey (Inwader77) please upload simple .blend files, there is absolutely no need for an 8Mb one to demonstrate this bug!


open - we will see proper hidden area.
select rendered, textured, material, wire shading mode - bug.
switch on dyntopo - proper work in all modes

Cool, I was unaware of this feature. The release notes mention it only works in solid shading mode. It also affects edit mode -- hidden parts remain hidden.

http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.63/Sculpt_Hiding
http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.63/Sculpt_Hiding/Implementation

The fix is to honor the ME_HIDE vertex flag when sculpting in other display modes. I don't think it should affect object mode or Cycles render previews.