Page MenuHome

selected faces in paint modes dont display properly
Closed, ResolvedPublic

Description

System Information
win7 64

Blender Version
Broken: 2.76.9 da7ddb6
Worked: (optional)

Short description of error
in vertex and texture paint mode selected faces look like they are masked and only 1 or 2 have proper brightness

Exact steps for others to reproduce the error
1.create cube
2.switch to wireframe shading
3.enter to vertex paint mode
4.press M then A to select all faces

Event Timeline

item412 (item412) added a project: BF Blender.
item412 (item412) set Type to Bug.
item412 (item412) created this task.
item412 (item412) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Please follow our submission template and guidelines and make a complete, valid bug report, with required info, precise description of the issue, precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.
Also, screen shots could help here.

2.76.4 df6264f selected faces are white, expected behavior

2.76.9 da7ddb6 same selected faces

Campbell Barton (campbellbarton) raised the priority of this task from Needs Information from User to Confirmed, Medium.Feb 9 2016, 4:40 PM

Bisected to rBd346ed3b105f830f5f1862054ca233d27afe28d5 (will investigate tomorrow unless someone else fixes :) )

Have a fix for this but discovered a related bug... will try resolve both before committing.