Page MenuHome

Crash when VSE attempting to play back long video files with ac3 audio
Closed, ResolvedPublic

Description

System Information
Windows 8.1

Blender Version
Broken: 2.76
Worked: (optional)

Short description of error
Blender will often crash when the VSE plays back a video file with AC3 audio from some point other than the start of the video.

Some notes:
Only happens with a file with audio and video (just importing an AC3 file isnt enough).
May only happen with h264/ac3 combination, I have not tested it with any other video codecs.
The longer the video, the more likely the crash... a 5 minute video will not trigger it, a 11 minute video will sometimes trigger it, and a 1.5 hour video will always trigger it.
The crash will be triggered on playback or scrubbing if audio scrubbing is enabled (also, scrubbing with the audio scrubbing not enabled will not crash).
Aggressive play/pause and scrubbing is more likely to trigger the crash on shorter video files.
Deleting the video track before playback will not prevent the crash, deleting the audio track will.

Exact steps for others to reproduce the error
Open Blender
Switch to the VSE layout
Load in a long video file with h264 video and ac3 audio
Move the play cursor to a point after the start of the video
Play the VSE

Details

Type
Bug

Event Timeline

hudson barkley (snuq) set Type to Bug.
hudson barkley (snuq) created this task.
hudson barkley (snuq) raised the priority of this task from to Needs Triage by Developer.
Campbell Barton (campbellbarton) triaged this task as Needs Information from User priority.

Cant redo this error.
Could you test if this sample h264/ac3 files cause an error? (

, )

If not, you will need to upload or link to some sample file.

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

No news since one week…

Ive been away a bit, didnt have any time to test.
Hopefully you will still get notified of the posts when this is closed?
Anyway, those test files do not cause the crash for me either. I think it is related to the resolution or size of the video, or maybe the container, or maybe due to some encoding settings... the files it crashed with were 1080i 8000kbps h264 and ac3 in an mp4 container.
Doing some tests today but reencoding the files takes a while, ill post results when I can narrow it down a bit.

ok, managed to reencode the test file and it seems to make blender crash every time.

Strangely, when I encoded it with blender using what appears to be the same settings, it will play back fine, but when I reencode it with avanti (ffmpeg frontend), it now crashes blender...

Yes, we still get messages even once report is closed. ;)

So, I cannot reproduce any crash here with your file and latest master, but we updated ffmpeg in upcoming 2.77 release, so please:

  • Give us your exact Blender, OS and GPU (including drivers) versions, as requested in the template!
  • Ensure both your OS and drivers are fully up-to-date.
  • Try the latest build from our buildbot.
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • Launch Blender from the command line with -d option and attach as text file here any error printed out in the console (do not paste it directly in comment).
  • Try different 'audio devices' (sound backends, in User Preferences, System tab).

Seems that the latest version of blender from buildbot does indeed fix this! Fantastic!

Note, I wrote all this before testing the latest build, ignore it if its not needed:
Tried with factory defaults and different audio devices, no change.
Fully updated OS, crashes on both Windows 7 64bit with a geforce 650, and Windows 8.1 64bit with a 860m.
Last drivers that support the graphic card on the win7 machine, not quite the latest drivers on the win8 machine, but downloading the latest now.

Bastien Montagne (mont29) closed this task as Resolved.Mar 2 2016, 8:16 PM

Good, then think we can assume issue was with older ffmpeg used in 2.76 and previous. Thanks for the report anyway. :)