Page MenuHome

Plane track ignores absolute scaling of image
Closed, ArchivedPublic

Description

System Information
Ubuntu 15.10 64big Geforce 970M

Blender Version
Broken: Blender 2.76b official

When using a scale node for an image the plane track deform node will still use the original image bounds for the plane track deform, thus for example scaling the image further down.

The bug appears to happen in the scale node. It does scale the image, but does not change the image bounds, even when set to absolute.

Exact steps for others to reproduce the error
In the attached file, when the top of the 3 image nodes is plugged into the upper scale node, you see the effect. The middle image is exactly 275 x 275 and thus not effected.

Details

Type
Bug

Event Timeline

Gottfried Hofmann (gottfried) updated the task description. (Show Details)
Gottfried Hofmann (gottfried) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) closed this task as Archived.Feb 23 2016, 10:37 AM
Sergey Sharybin (sergey) claimed this task.

Unfortunately, it's just the way compositor currently works and there's no simple fix for this: the system don't know resolution in advance (because size are actually sockets) and it's not really possible to evaluate the tree when detecting the resolution.

Thanks for the report, but considering it a general TODO related on making the whole system properly canvas aware.