Page MenuHome

Enhanced 3D Cursor plugin failed to snap on 2.77
Closed, ResolvedPublic

Description

System Information
Windows 7 64bit
Intel Core i7 3770

Blender Version
Broken: (2.77rc1 hash b594b25)
Worked: (2.76b and earlier)

Short description of error
Enhanced 3D Cursor plugin can snap the cursor to face/edge/vert in 3D view,but on 2.77rc1 the function has failed.The cursor does move yet the snap function does not appear to have worked as expected.
Possible reason for this may be the change over the lower level GL drawing methods that may cause some problem to 3D depth reading,I think the author needs a indepth checking for the issue.

Expected effect:

Current under 2.77rc1

Thanks in advance for looking into it.

Details

Type
Bug

Event Timeline

YimingWu (NicksBest) added a project: Add-ons.
YimingWu (NicksBest) set Type to Bug.
YimingWu (NicksBest) created this task.
YimingWu (NicksBest) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Normal priority.

Sorry for the delay.
The problem was actually caused by the change of the ray_cast() return value in Blender 2.77, so snapping didn't work at all.
It should be fixed now.

dima glib (dairin0d) closed this task as Resolved.Mar 5 2016, 6:27 PM

Ah, I suppose I should mark it as "resolved".