Page MenuHome

Point light not working properly inside a volume while rendering with GPU
Closed, ResolvedPublic

Description

System Information
Windows 10 64 bits, Nvidia GTX 670

Blender Version
Broken: Blender 2.77 RC 1 b594b25

Short description of error
Point light not working properly inside a volume while using GPU. It lightens the material, but not interacts with the volume. With CPU rendering, it works fine.

Exact steps for others to reproduce the error
Place a point light inside a volume, with another mesh to lighten.

The light in the example comes from HDRI environment map and from point light.

Blend file with the problem
CPU viewport, working fine
GPU viewport, not working properly

Details

Type
Bug

Event Timeline

Pablo (Pablo-Trensardina) raised the priority of this task from to Needs Triage by Developer.
Pablo (Pablo-Trensardina) updated the task description. (Show Details)
Pablo (Pablo-Trensardina) set Type to Bug.

Cant verify on Blender 2.77 RC1.

Hi you set all samples to 0 in Sampling setting.
No Bug.

Opensuse Tumbleweed x86_64
Intel i5 3570K
GTX 760 4 GB /Display card
GTX 670 2 GB
Driver 361.28
Intel opencl_runtime_15.1_x64_5.0.0.57

EDIT: Don´t saw sampler settings at first view.

I can confirm bug. GF960 GTX, Win10 64b, Blender 2.77RC1
2.76b is fine

Hi Cenek, you cant set sampling to 0 in 2.76b, it automatically switch to 1.
If you switch volume samples to 1 in 2.77 RC1 it is working too.

Mib

This is a forbidden configuration, which should not have ever happened. I managed to "break" the setup using python code, this will be fixed by @Campbell Barton (campbellbarton) soon.

I also found default value for volume samples was wrong, it was fixed in rB3d3d491.

The reason it works in 2.76b is because buttons were allowed to clamp values on display, which was causing other issues.

Just set samples to 1, and wait Campbell to fix python bindings so scripts can't violate this again,

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Normal.Mar 2 2016, 11:13 AM
Sergey Sharybin (sergey) closed this task as Resolved.Mar 7 2016, 10:30 AM

Considering the issue solved now. Thanks for the report!