Page MenuHome

Install Deps OSL 1.7.1 and clang-3.5
Closed, ResolvedPublicPATCH


Hey there,

the default version for llvm/clang used in the script is 3.4. Since I didn't find clang-3.4 for my distribution, I tried 3.5 and 3.6. However, both of them faild building OSL 1.7.1.
Clang-3.5 requires OSL_BUILD_CPP11 to be set whereas OSL 1.7.1 does apparently not build with Clang-3.6 at all (

So this patch should fix the Clang-3.5 problem and issue an error in case using a newer Clang version.


Event Timeline

Stefan Büttner (xadrin) raised the priority of this task from to 90.
Stefan Büttner (xadrin) updated the task description. (Show Details)
Stefan Büttner (xadrin) edited a custom field.

Well, better use this patch >.<

Thanks for the patch, but it’s not only an issue for llvm/osl, it’s also an issue in Blender itself then, where you need to enable cpp11 etc.

So for now let’s keep install_deps as is, it’s already complicated enough, and let’s stick to officially supported version of llvm (3.4). Will update the script to only accept 3.4 packages (will build own llvm/clang otherwise).

Okay. Yet this it still fails on my system because the scripts assumes that if llvm-3.4-dev is available, also clang-3.4 is available. However, this is not the case (although I'm not sure if that's a problem of my system due to misconfiguration, though). But apt-cache show llvm-3.4-dev shows no dependencies to clang. So the script should also check if clang is available, shouldn't it?

What about something like this?

Good point. In fact, it’s clang which depends on llvm (same version), so should be enough to check on clang package version.