Page MenuHome

Compositing 'Glare:Fog Glow' horrible distorted output
Closed, ArchivedPublic

Description

System Information
OSX El Capitan on Mac Mini (Late 2012) Intel HD Graphics 4000
Also verified on
Fedora Workstation 23 on Dell i7 Optiplex with Radeon HD Graphics (open source drivers)

Blender Version
Broken: 2.75a (c27589e), 2.76 (Fedora 23 Package), 2.77 (22a2853)

Short description of error

Using the compositor 'glare' node with the 'Fog Glow' setting on this render produces very large nasty artifacts. It's not a single file bug, as the same issue shows up on different renders of the same scene, and different EXR output files, different EXR formats, etc. This is visible with OpenCL on and off, in the preview (background) and in the final (F12) output.

Exact steps for others to reproduce the error
Open the .blend, press 'F12' for render.

I've also attached an .EXR which causes this.


Details

Type
Bug

Event Timeline

Daniel (danthedeckie) updated the task description. (Show Details)
Daniel (danthedeckie) raised the priority of this task from to Needs Triage by Developer.
Daniel (danthedeckie) set Type to Bug.
Sergey Sharybin (sergey) triaged this task as Confirmed, Medium priority.Apr 5 2016, 11:36 AM
Sergey Sharybin (sergey) claimed this task.
Sergey Sharybin (sergey) closed this task as Archived.Apr 26 2016, 2:15 PM

Looked into the issue and it's some specific of math by the looks of it. Since there are other known issues with this node (threadability mainly), would consider it a TODO related on finding a nice threadable algorithm which isn't originating to implementation from a stone age (as the current implementation does, unfortunately).