Page MenuHome

Slow GPU render
Closed, ArchivedPublic

Description

i7 4790, nVidia GTX 960, Windows 10

Blender 2.77 64Bits

The same render made in the version 2.76b, is much slower in version 2.77

Details

Type
Bug

Event Timeline

Aaron Carlisle (Blendify) triaged this task as Needs Information from User priority.

We need more information than this.

  • Please upload the file that is giving a regression
  • Give times from 2.76b and 2.77

Times

2.76b - 3:21.62
2.77 - 5:35.95

Thomas Dinges (dingto) raised the priority of this task from Needs Information from User to Normal.

Kubuntu Linux 14.04 64 bits, GTX 960 4GB, i7 3770

Well, it seems that Leandro has not packed textures. But I can confirm the problem with this scene "ExpositorQoolEvotution_V1.blend", both CPU and GPU (rendering without textures):

Blender 2.76b:
GPU (256x256): 03:21.47
CPU (32x32): 04:26:34

Blender 2.77:
GPU (256x256): 06:06.93
CPU (32x32): 06:51.67

The problem does not occur with BMW27.blend scene, it is almost the same time with 2.76b or 2.77 in BMW scene,

Same issue happened in another scene. And sorry, I forgot to pack textures.

Slowdown also occurs on the GTX580 Windows 7

Hi Aaron and Thomas. Another guy, sanjio666, at Blenderartists, had the same issue, and described it with more details: http://blenderartists.org/forum/showthread.php?396102-GPU-render-slow-in-2-77&p=3031794

Hi, check file on:

Opensuse Leap 42.1 x86_64
Intel i5 3570K
RAM 16 GB
GTX 760 4 GB /Display card
GTX 670 2 GB
Driver 361.42

If I switch environment back to RGB 2.76b and 2.77a render with same render time (GPU).
If I add own environment map Blender 2.76b need about ~50% of render time compare to 2.77a.
This seams different error to the GTX 980Ti/TitanX problem.

Mib

Sergey Sharybin (sergey) closed this task as Archived.
Sergey Sharybin (sergey) claimed this task.

This issue here is caused by the fact that you go from file saved in Blender 2.77 to Blender 2.76. This makes it so Cycles settings which were not explicitly changed to differ if some defaults changed. In the file from the original report it is World MIS which is responsive for the slowdown. MIS usually reduces noise, but doesn't go for free. If it's causes more slowdown that noise reduction you can disable it.

Thanks for the report, but it was an intentional change listed there https://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.77/Cycles#Settings