Page MenuHome

Cursor remains a 'double headed arrow' when opening the 'Add Node' menu.
Closed, ResolvedPublic

Description

System Information
Windows 10 64-bit, Nvidia gtx 570, Nvidia gt 610

Blender Version
Broken: 2.77a, 9f39619 (latest 64-bit build)
Worked: (optional)

Short description of error

If you place your cursor over the edge of a node the cursor turns into a double headed arrow to indicate that you can resize a node. If you press Shift+A to open the 'Add Node' menu while the cursor is in this 'double headed' state the cursor will remain like this while browsing the menu and while placing a new node chosen from the menu.

I know it's a trivial thing, but it just seems a little odd when it happens.

Exact steps for others to reproduce the error

  1. Add a node to any of the node systems in Blender, e.g. compositing nodes.
  2. Hover your cursor over the edge of a node to change it to the 'double headed arrow'.
  3. Press Shift+A to open the 'Add Node' menu.
  4. The cursor remains 'double headed' while browsing the menu.
  5. Clicking on a node in the menu will add the node and the cursor remains the same.
  6. Placing the node down finally changes the cursor back to the normal arrow.

Event Timeline

Ray Mairlot (madog) set Type to Bug.
Ray Mairlot (madog) created this task.
Ray Mairlot (madog) raised the priority of this task from to Needs Triage by Developer.

Its only possible to open the menu in certain cases (not most of the time in own tests).
So the bug may be that you can open the menu while hovering over the region edge.

Sergey Sharybin (sergey) triaged this task as Confirmed, Medium priority.

@Campbell Barton (campbellbarton), the issue happens when you open the menu when mouse is over the node corner (right-bottom corner which you use to resize node)

@Julian Eisel (Severin), mind having a look perhaps :)