Page MenuHome

VSE audio pitch changes the speed of the audio
Closed, InvalidPublic

Description

System Information
Windows 10
Intel HD 4600

Blender Version
Broken: Master
Worked: (optional)

Short description of error
VSE audio pitch changes the speed of the audio along with pitch. This is a little weird, if the functionality is correct then the option should be titled "Speed"

Exact steps for others to reproduce the error

  1. Add audio strip
  2. Change the pitch

Details

Type
Bug

Event Timeline

Aaron Carlisle (Blendify) set Type to Bug.
Aaron Carlisle (Blendify) created this task.
Aaron Carlisle (Blendify) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) triaged this task as Normal priority.

It's always a good idea to attach exact .blend with exact audio file which demonstrates the issue.

Please do a little more research before opening bug reports like this.

What Blender offers here is called pitch control and changes speed and pitch at the same time, as it is a rather simple process that has been around for a long time. Traditionally, it has always been called just "pitch" in Blender since before 2.5 (when I started developing for it) most likely a lot longer. As the proper term is pitch control and not speed control, even though it changes both, "pitch" is the correct naming.

Controlling only either of those values is called time stretching, pitch scaling or pitch shifting (the last term is a bit ambiguous as it is also sometimes used for pitch control). This process is more complex and not currently supported by Blender.

Joerg Mueller (nexyon) closed this task as Invalid.May 24 2016, 10:18 AM

Before reporting the bug a cross-referenced it with Audacity and it has 3 controls:

  • Speed: Controls both the pitch and the tempo
  • Tempo: Controls the actual speed of the audio
  • Pitch: Controls the actual pitch of the audio
Hossein Shah (hk1ll3r) reopened this task as Open.

I'm new to blender, not sure if this is the right place but here I try...

I'm using blender 2.79b and the pitch only changes the pitch. To the length of the audio stays the same and it plays all the way through the strip. The new behavior is inconsistent with what is being discussed here... according to @Joerg Mueller (nexyon) 's terminology, blender does pitch control (speed and pitch at the same time) where as I'm seeing only a pitch change (pitch scaling).

Has this behavior changed since? Can you reference the bug / task? Thanks.

@Hossein Shah (hk1ll3r), instead of re-opening old reports, make a new one. With all the information requested there.
Please note that this is not really a place for discussion, but for a bug tracking, where artists report reproducible bugs and developers fix them. For discussions there are other channels like devtalk.blender.org, or blender artists.

Joerg Mueller (nexyon) closed this task as Invalid.Feb 12 2019, 10:29 AM

@Hossein Shah (hk1ll3r), you're right the strip length stays the same, but that doesn't mean that the speed doesn't change. If you have a strip of full length (not cut on any side) and you change the pitch to 2, you'll end up with double pitch and double speed, but the strip will stay the same length, meaning that it's silent in the second half. We intentionally don't change the strip length when the pitch is changed, since this can cause many problems, especially when you animate the pitch. I hope this clarifies the issue. If not, please ask further questions on devtalk.blender.org as @Sergey Sharybin (sergey) suggested.