PASCAL GPUs can't perform renders (Cuda binary kernel 6.1 not found)
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
Win 10x64, GPU: Asus GTX1080-8G

Blender Version
Broken: (example: 2.77a 22a2853)

Short description of error
When trying to render using GPU, I get: "Cuda binary kernel for this graphics card compute capability (6.1) not found."

Exact steps for others to reproduce the error
tried renaming kernel_sm_52 to kernel_sm_61, but throws an error "Cuda error at cumoduleLoad: Invalid Source"

Details

Type
Bug
Alex (almrender) added a project: BF Blender.
Alex (almrender) set Type to Bug.
Alex (almrender) added a subscriber: Alex (almrender).
Thomas Dinges (dingto) closed this task as "Archived".May 29 2016, 7:35 PM

We don't consider that a bug yet. In order to support Pascal cards, we need to build kernels with the CUDA Toolkit 8. There is only a RC of the CUDA Toolkit 8 available yet, and so far only for registered developers. https://developer.nvidia.com/cuda-toolkit

As soon as the final release is here (nvidia says August, source https://devblogs.nvidia.com/parallelforall/cuda-8-features-revealed/) we will build Blender with sm_61 kernels.

are there any (hacky?) workarounds to have blender work with 61? Waiting till august to see the first tests is so long!

I am sure that third party builds (Graphicall?) will appear soon (once the RC can be downloaded without the need for an account). But for official support in our builds, we will wait for the final CUDA Toolkit release.

give this a whirl: {F315223} Download Removed, Please download a build from builder.blender.org, which support Geforce 1xxx Pascal cards. No need to manually download anything.

Hi LazyDodo

I run blender with your Kernel_sm_61.
(I bought Geforce GTX1080 today!)

It works for me.

My Machine is following:
OS: Windows 10 Pro
GPU:GeForce GTX 1080 Driver version 368.39
CPU: Core i7-4790K 4GHz
Mem:16GB

Performance is equal to Geforce 670 ;)

thanks.

Re: Kernel_sm_61
Hi LazyDodo
Yes - it works! with Blender 2.77a and the following system:

Windows 10 Pro 64 bit version 1511 (OS build 20586.318)
GPU: Geforce GTX 1080 G1: driver version 368.39
MB: MSI z77a-gd65
CPU: i7-3770K @3.9GHz
RAM: stupidly much.

Can't comment on performance as just installed the card today, just that it's faster than the 760.
And what a day: started off chasing the courier down the road as he didn't knock, then lots of swearing getting the card to run: I'm not very techie :P

Thank you so much Ldd.

Hello LazyDodo,

Win10 64bit
GPU1: gtx 980ti GPU2: gtx 1080
cpu: i7 6700K on asus z170 with 32 gb ram

I have a lot of render-errors (see screenshot - you can see what was rendered by 1080 and by 980
I think there is no AA used in this kernel

But it is very strange.. Rendering Scenes like "BMW Benchmark" is running well (with 2 gpu only 44 seconds) and no render-error..

and 980 is faster then 1080 with this kernel

best regards
jan

Hey there!
I can confirm that the kernel works for my GTX 1070 on Windows 7 x64 and Linux Mint 17.3. Jan Buran is right, there seems to be no AA.
Thanks to LazyDodo for providing the kernel!
I'm looking forward to the official release. :-)

Just bought a GTX 1070 and am getting the same error.

Where do I install the kernel_sm_61 file?

Thanks!

@Shai Getzoff (Shaisgs):
Copy the "kernel_sm_61.cubin" file to this location:
blender-2.77a/2.77/scripts/addons/cycles/lib

Another comment for those who would like to experiment with LazyDodo's kernel: The issue with Anti-Aliasing seems to be gone when switching Sampling settings to Branched Path Tracing.

Thx Thomas, with branched path AA works fine

@Shai Getzoff (Shaisgs):
Copy the "kernel_sm_61.cubin" file to this location:
blender-2.77a/2.77/scripts/addons/cycles/lib

Thanks!

LazyDodo,

kernel_sm_61.cubin also works on my Linux Mint 18 with GTX1080 (same issue about AA deactivated on Sampling settings thank you Thomas for the workaround).

Thanks a lot because CUDA 8 RC seems currently unstable on Linux (last gcc update not yet integrated by NVIDIA and other minor issues).
Save me a lot of time.

Thanks for the Kernel, working well on my Win8 with GTX 1070

It's probably better to grab a nightly build from the buildbot which has build in support for the 10xx cards, than to use the kernel i put up in this ticket. Many optimizations have been done since i posted it.

The file Kernel_sm_61 " causes the following error: module installled from 'E\\blender files\\addons\\kernel_sm_61.zip into 'C\\users\\carlshome\appdata\\roaming\\blendr foundation\\blender\\2.77\\scripts\\addons' {} <1> event has invalid window

this is on a system of the following:
Windows 10 64 bit
with a 1070 video card

@carlo Foremanana (foremancr) This is not a addon file.

This report has been solved, please download a build from builder.blender.org, which support Geforce 1xxx Pascal cards. No need to manually download anything.

You don't need that file, just use a new Blender version from builder.blender.org. Blender now supports Pascal cards...

I'd like to argue your definition of 'great video' given I deleted the attachment days ago to prevent people from running 'badly optimized old stuff' , the new buildbot builds are much better.

@LazyDodo (LazyDodo)

How do I download a buildbot build/ i tried blender.org but whatever i download pissed the hell out of all my anti viruses

Silly question, how do I install the builds?

You download it and extract / run it, just like any other software.

Yea just got the GTX 1080 and have tried the experimental builds of Blender.

It does cycle with the card in GPU mode, but the aliasing is awful. I have been all morning trying to figure out why.

I know on the current official build I can render "text" in regular CPU mode, and there is very little aliasing of the lines.

But what ever is happening with these new Pascal cards is messed up.

Now I did notice my old gtx 780 had some aliasing issues as well, but not like this. But i alsos did not use it much, but now I really need it to work. I am making my own campaign cards and they just don't look good all aliased.

Is there a plug in for anti aliasing in cycles?

If you didn't notice the announcement on the home page, there are test builds for 2.78 available now. These do include an msi installer for Windows too.

I'm not noticing any aliasing in renders with my 1060 on these builds. That is as long as I'm using enough samples (the "Final" sampling preset works pretty well--24 square samples), but that goes for the CPU renders too. The output of the CPU vs. GPU looks to be the same, but the GPU is much faster.

So, one more silly question. If I download the latest build now, will the error "Cuda binary kernel for this graphics card compute capability (6.1) not found." happen when I render with my GTX 1070? And which one should I download? ''blender-2.77-f0159d1-win64.zip'' or ''blender-2.77-f0159d1-win64-vc14.zip'' ?

Yes it should work on your 1070 and you should download `blender-2.77-f0159d1-win64.zip`

Yep tried out today's build and wow the render is faster. A lot faster now seeing what a GTC 1080 really can do!

I am thinking maybe the aliasing is do to using a 32 inch 1080P tv for my monitor, but the thing is other stuff I do on it is not aliased so bad.

Daily Build is now perfect for pascal-tech! With the last build.. one week ago.. many crashes..
But now... I used severel shader (with sss, reflective, normal, etc.) and there was no Crash.

An here you can see the Speed:

Ok I have long winded thing about working with HD tv monitors over 27 inches below this.

I put this up first for one simple question because I am looking for a work around for what I am talking about in the next post.

Is there a way to increase the DPI in the rendered image? I see they are 72 DPI.

I want to render at 300 DPI then shrink them down that way and see if the aliasing problem goes away.

Ok so far I do think the size of the monitor I am using is throwing off what I see on the screen, I am seeing the same issue when using Inkscape and the vector drawing, it should not be aliased.

It comes down to this: any LCD, LED, HD monitor over 27 inches, will have aliasing problems period! The number of pixels are being stretched over 27 inches, you don't see in the living room because your sitting far enough away that your screen look beautiful!

However I can honestly says when gaming with my current set up crisis and GTA 5 looks perfect on this 32 inch Sharp flat screen, I mean there is little to no aliasing in the games. And, now with this GTX 1080, you tube video look more crisp and clear, my old gtx 780 they looked good but they almost look like Im looking inside a 3d world on my computer screen.

So I can not figure out why rendering in cycles with Bender does not.

So now I am either going to have to take the monitors back and get a 4K or find a work around, I know GTX 1080 are 4K ready but we all know they will not be perfected for another 3 generations of video cards, yea they can play older and current games at 4k now but the next game to come out that is 4K made forget it.

Now you see all of this important when it comes to using Blender when making movies and games as well. 4K is not ready yet TV networks are far from broadcasting in it and not everyone is jumping to buy 4k TV's, hell I am not and I can get one at Wall mart for $400, less hen what i paid for my 3 1080p 32 inch set up!

So what is going to give?

Us the users, Blender or the market?

I would rather keep my 3 monitor set up with my GTX 1080 video card for about 3 to 4 years as i did with my old GTX 780 I waited 3 years before upgrading, and it was worth it.

So does anyone have any ideas how to get blender to render in cycles on large screen monitors AKA 1080 tvs (over 27 inches)?

Hey the 300 dpi work, makes a big image, but yea it works.

Save image, gimp still sees 72 dpi though, but oh yea there is a huge difference in how the render image comes out, even on 32 inch Sharp tv

Alan Fong (AlanFYL) added a comment.EditedSep 3 2016, 7:26 AM

But when I run blender which is downloaded from the build, it says the application might put my PC at risk. Is there a problem or just run it anyway?

I was too late to grab yesterdays build, but here's a scan by 45 virus scanners of todays build.

https://www.virustotal.com/en/file/b59ddf3613bcbcfc1d2ec8c1d06f5b0cc6f4171be40446802251a6ee39193bbb/analysis/1472882359/

The popup it gave you is probably just warning about 'unknown sources' given the builds aren't signed with a cryptographic key

Thanks LazyDodo, it works.

please can help me for link : kernel_sm_61.cubin ??

No longer needed, just grab 2.78a from the website.

i can't render cycles with gtx 1060
notif

please help me all

Right next to that warning is v2.74. You're still running version 2.74. Support for CUDA 6.1 was added in 2.78. Install the newest version, 2.78a, and it will work.

i'm use 2.78a but close windows before open file .blend
help me please all

Is this still a thing in 2.78a e8299c8 ?
I think my gtx 1060 performs relatively bad.

@Simon Razer (Simonrazer) please start a new bug report giving more information.

Nevermind getting Blender from the buildbot 2.1* the speed : )