Page MenuHome

getActionName() still returning Action name that already stopped.
Closed, ArchivedPublic

Description

System Information
Linux, Ubuntu-Mate 14.04, nVidia GT620

Blender Version
Working 2.76 (from blender.org)
Broken: 2.77, 2.77a (from blender.org)

Short description of error
getActionName() returns running Action name when running... but still returning the same name when Action finished. As the API says:

getActionName(layer=0)
Gets the name of the current action playing in the supplied layer.

So, if there's no Action playing, it should return nothing or None.

Or is it at purpose, to know what last Action was? If so, API documentation should say that.

Exact steps for others to reproduce the error

  • Open the file with 2.76 and enter in Game Engine or run it with BlenderPlayer. Look at the console
  • Do it with 2.77 or later.

Details

Type
Bug

Event Timeline

Mario Mey (mariomey) raised the priority of this task from to Needs Triage by Developer.
Mario Mey (mariomey) updated the task description. (Show Details)
Mario Mey (mariomey) set Type to Bug.
Aaron Carlisle (Blendify) closed this task as Archived.Jun 29 2019, 2:19 AM
Aaron Carlisle (Blendify) claimed this task.

This task is being closed because the BGE has been removed in Blender 2.8.