Bevel fails in this case
Closed, ResolvedPublic

Description

System Information
WIndows 8 64bit | GTX680

Blender Version
Broken: 2.77a abf6f08

Short description of error
Just got strange bevel result.

Exact steps for others to reproduce the error
See attachement. Thanks.

Leon Cheung (leon_cheung) updated the task description. (Show Details)
Leon Cheung (leon_cheung) raised the priority of this task from to Needs Triage.
Leon Cheung (leon_cheung) set Type to Bug.

Is that by a modifier or Ctrl+B?

I cant reproduce it, mine comes out like this:

same blender version but on windows 10 and gtx 970

@eroMoD, it seems you selected all edges. To reproduce, just select the corner loop. It both occurs with Ctrl B and modifier ( with Vgroup method).

Oh, I see. But it looks like disabling loop slide gets rid of it, does it work for you too?

It does work. Thanks for the info! :)

Can anyone close this report? I don't know how...

eroMoD (tostrong4you) closed this task as Resolved.Jun 18 2016, 4:24 AM
eroMoD (tostrong4you) claimed this task.

I can but developer told me not to.
But maybe you are allowed to do it to your own post.
when writing a comment, under "action" you can choose "change status"
and switch "status" to "resolved".

I saw your face on the stack exchange, you make great answers btw.

eroMoD (tostrong4you) reopened this task as Open.Jun 18 2016, 4:24 AM

Let’s not close the report just because a workaround was found ;)

@Howard Trickey (howardt) will let you decide whether this is a bug or an expected behavior :)

Bastien Montagne (mont29) triaged this task as Normal priority.Jun 21 2016, 4:59 PM

This looks like a bug I want to fix, so we'll leave this report open and I will fix the bug. Glad there's a workaround for now.