Bevel is not working with Vertex group
Closed, InvalidPublic

Description

System Information
W10 64b, GF770

Blender Version
2.78

Short description of error
Hello, I want to do some procedural modeling tools addon. But I have problem with this behaviour. Is it bug or limitation? I have selected edges in group:


But when I have no special subdivide, I am getting wrong bevel masked with Vertex Group.

Exact steps for others to reproduce the error

  1. Open

Details

Type
Bug

I don't understand what behavior you are expected. The example file looks working as expected to me. When you specify "Vertex Group" as the selection method in the Bevel Modifier it works as follows:

  • all the given vertices are selected, and then those induce certain edges to be selected (the ones with selected vertices at both ends)
  • those edges are beveled

That seems to be what is happening in this example. If I am missing something, please explain.

I expected that bevel will be only on side of cube. Because I added only selected edges to group. But without additional splitting it is not possible. I wanted to reach look of left box, but with topology of right box. I tried Bevel Weight Edge parameter and Vertex Group. But it is not possible to reach without splitting. I am expecting that information about beveling (even Bevel Weight) is stored in vertex not in edge. So it is limitation.

Howard Trickey (howardt) closed this task as Invalid.Oct 5 2016, 1:24 PM

OK, I understand now.
Yes, it is a limitation of using Vertex Groups that you cannot precisely specify which edges you want to include. Because, as I explained earlier, all edges that have both ends in the vertex group will be beveled, and for the simple unsubdivided cube case, you cannot select all the vertices and yet only have a subset of the edges beveled. This is a case where it would be good if Blender also had Edge Groups, but it does not. Using Vertex groups to specify edges to bevel was an imperfect workaround to not having edge groups.

You can achieve what you want with Bevel Edge Weights, however. Those are stored in the edge, not the vertices. Select the just edges you want to bevel, then in the n panel, change the 'Mean Bevel Weight' under 'Edges Data' to 1.0, and in the modifier, change the Limit Method to 'Weight'.

I am closing this bug as Invalid, because things are 'working as intended' (until and if we decide to add Edge Groups to Blender).

Thanks for explain.

I know Mean Bevel Weight, but it influences all Bevel Modifiers in the stack. I wanted to specific edges for specific Bevel Modifier. My intention was make addon with procedural beveling. So I hope will be Edge Group in Blender one day :)

Thank you