Page MenuHome

Texture Paint > External > Quick Edit > Error Message
Closed, ArchivedPublic

Description

When I am trying to create a design on an object I have in Blender 3D, I follow these steps:

  1. Select Texture Paint
  2. Select External
  3. Select Quick Edit

Then an error message pops up saying the image editor can not found, although I correctly set up in User Preferences under the files tab, in the image editors section, to use photohshop cs6. Even though I have it completely set up correctly, (I have checked many times) it still gives me an error message that the image editor can not be found.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Oct 10 2016, 10:11 AM

What do you put in that external editor setting exactly? Did you check that using the exact same command in windows' command line does work?

This is copied directly from my User Preferences where I place the path for the external image editor.

C:\Program Files (x86)\Adobe\Adobe Photoshop CS6\Photoshop.exe

Error: Image editor not found, please specify in User Preferences > Files

Weird, mind making a screenshot of User Preferences -> File ?

Sure, I'm not home right now but I will be in about 3 hours. I will take detailed screenshots when I get back and walk you through every step that I take.

Still can not reproduce the issue.. Please check the exact message from the system console (Window -> Toggle System Console). There should be more clues there about the issue.

Additionally, try this:

  • Copy path from the blender's user prefs
  • Hit Win-R combination
  • Paste the path there and hit Enter
  • See if that properly starts your photoshop.
Aaron Carlisle (Blendify) closed this task as Archived.Nov 3 2016, 7:26 PM
Aaron Carlisle (Blendify) claimed this task.

It has been a long time with no reply. Closing.

Sorry for the delayed response, I've been very busy. Here is a screen shot of the console.

Can't repro either. What windows version is this?

@LazyDodo (LazyDodo) i can reproduce it with Krita on Win7. From the win file manager right click on krita.exe > Properties > Compatibility > enable Run this program as an administrator.

Seems that in that case, windows can't pop up the UAC warning about raising privileges and craps out when the executable is called from Blender.

I'm almost positive I am still running on Windows 8.

Bastien Montagne (mont29) closed this task as Archived.Nov 11 2016, 4:03 PM
Bastien Montagne (mont29) claimed this task.

Just don’t run krita or photoshop as admin, this makes no sense and is potentially dangerous. Not a blender bug anyway, that’s windows issue.

Josh (joshba78) added a comment.EditedNov 13 2016, 6:05 AM

I'm pretty sure I am not running Photoshop CS6 as administrator because if I right click on it, it gives me the option to "Run as Administrator." I am by no means a computer expert, I was just trying to use Blender 3D and Photoshop together the way I saw done in a tutorial on youtube. Thank you for the help. Hopefully I can figure out someday how to get my Blender 3D to open Photoshop CS6 through the "External Editor" process, I appreciate the time you spent trying to help me.