Page MenuHome

3D Viewport Lag with NVIDIA 373.06 Driver (and Earlier)
Closed, ArchivedPublic

Description

System Information
Windows 8.1 Home, Intel i7 5930K, 32 GB RAM;
EVGA GTX 970 SC, NVIDIA Driver: 373.06

Blender Version
Broken: 2.77a Hash: abf6f08

Short description of error

Hi all, this issue has persisted literally for months, forcing me to continually roll back to NVIDIA Driver 359.00 which was from 11/15/2015. For some reason, that driver did not exhibit the following issue:

In the 3D viewport, when I hold down Shift + Middle Mouse button to pan the view, there is always a delay of a few milliseconds before the screen updates. This behavior is exhibited even with the default cube of 8 vertices, there is always a lag. Is this an NVIDIA issue or a Blender issue? I would really like to be able to use the latest driver with Blender, as it has bug fixes that works with other programs like UE4. Thanks so much for any assistance with this!

Exact steps for others to reproduce the error
Open a new default project on a system with a GTX 970 running driver 373.06. Shift + Middle Mouse click to pan the viewport. There will be a fairly consistent lag EVERYTIME before the view updates, in other words, if you HOLD the middle mouse button down, you'll only notice the lag ONCE at the start; but if you release and then Shift + Middle Mouse click again, and again, and again... each time you will keep seeing the lag. Driver 359.00 does not exhibit this behavior in Blender. I am not certain if at some point another driver newer than 359.00 also worked, because when I tested several months ago, the exact same issue existed.

Details

Type
Bug

Event Timeline

Adam Janz (Copperplate) closed this task as Resolved.Oct 17 2016, 5:33 PM
Adam Janz (Copperplate) claimed this task.

This appears to be an NVIDIA issue, as the problem goes away when:

  1. You enable Desktop Capture from the Privacy Control menu in GeForce Experience.
  1. You enable Desktop Capture from the Privacy Control menu in GeForce Experience, but you Disable "Instant Replay". This will actually make the condition worse. The irony is, though, as soon as you hit ALT + F9 to start screen recording in GeForce Experience, the viewport gets as smooth as butter. :-) I'm going to complain to NVIDIA about this.

Thanks!

I am setting this back to open, as NVIDIA claims this is a Blender-specific issue. The previous info I added about enabling Desktop Capture in GeForce Experience privacy control to "solve" the issue, and disabling live replay to make the issue even worse still applies. Obviously, something major changed between the way Blender responds to 359.00 and 373.06.

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Oct 18 2016, 11:46 AM

Blender does not do anything driver-version related, so it uses 359.00 and 373.06 drivers in the same exact way.

I've tried to reproduce the issue with 373.06 on laptop with Win7 and GT540 but the issue did not happen to me.

Hence some things to test/try:

  • Open command line (cmd.exe), and there: path\to\blender.exe --factory-startup and see if the issue happens there.
  • Check if you can reproduce the error on another machine.

Did NVidia guys give any technical information which will help troubleshooting what exact issue is?

Sorry, one more thing :)

Test 2.78 release and latets builds from builder.blender.org as well and see if the issue happens with them as well.

Thanks Sergey! I tested it out in Blender 2.78 with all the NVIDIA settings off and at first the issue appeared to be fixed, but when I launched a project from hard drive directly, sure enough, the lag was still there.

However, I determined what was causing it! For some reason, having Multisample set to 16 in Blender's preferences was causing this glitch with drivers newer than 359.00. I turned Multisample off, and there was no lag. The good news is that if I enable "Desktop Capture" from Privacy Control and "Instant Replay" in NVIDIA GeForce Experience, I can run Multisample x16 in Blender's preferences without any lag whatsoever. :-)

Unfortunately, 2.78 also has a display bug where you can see the UV seams of your model in Object Mode (when set to Textured view), which gets worse the further the camera is from the object (visible on an all-white texture in Blender Internal). This bug actually shows up in renders too, which means I should probably roll back to 2.77.

Have a good day!

~Adam

My bad... just checked 2.77a and it has the same UV seams issue. Apparently someone had the same issue as me back in 2007, so I guess this problem's been around for awhile. Wonder if anyone found a workaround for something with an all white texture and a distant camera? Anyway, feel free to set the original report to solved, if you wish. The NVIDIA GeForce Experience workaround seems to be an adequate solution. No idea why things had changed though on the newer drivers... except maybe when they recently overhauled GeForce Experience they broke something.

Just found the solution: The UV islands just needed more padding around them. Even though they looked clear, this mip map error would show up from a distance. :-)

It's very strange how enabling Sharing, Instant Replay, and Desktop Capture in NVIDIA GeForce Experience allows me to run Multisample x16 inside Blender without any glitching at 1440p... I just tested again to be sure. However, even if the original issue can't be fixed, this workaround does "solve" the problem. Thanks :-)

Bastien Montagne (mont29) closed this task as Archived.Nov 11 2016, 4:01 PM
Bastien Montagne (mont29) claimed this task.

This is definitively an NVidia dirver bug, if with one version of driver everything is OK and the next it’s not… that’s called regression. We cannot fix their drivers for them.

This is definitively an NVidia dirver bug, if with one version of driver everything is OK and the next it’s not… that’s called regression. We cannot fix their drivers for them.

That was my initial thought too. But Nvidia claimed if the problem only manifested with Blender and no other program, it was a Blender issue. I will have to contact them again and get them to look into it further.

Thanks!

~Adam

Hi Guys,

had the same issue, since version 350 or something. The lag was totally gone, as soon i activated the recording.
Have this issue on every workstation at work, with every Software. Maya, C4D, Blender and so on, on different GPUs and different drivers.

Had a conversation with an NVIDIA guy today. He told me this and for me it works.
I had the same issue with C4D now its gone, in Blender and C4D.

Try making these changes

a) Right click on the desktop and launch NVIDIA Control Panel --> Manage 3D settings.
b) Go to Global Settings tab.
c) In the setting window,
• Power management mode – prefer maximum performance
• Threaded optimization – off
• Triple buffering – off
• Vertical sync – off
• Maximum pre rendered frames – 3

Strange behavios is, that after i set the settings to default its still fluid. I think if i would do a restart with default settings the lag is there again.
But why should i do that :D :D

Have a nice Day,

Daniel

Thanks so much, Daniel! Yes, that does work, however, I noticed the settings only take effect once Blender is closed and re-opened (I tried changing the settings one at a time with Blender open to no effect). And resetting NVIDIA control panel back to default does cause Blender to re-exhibit the issue (when closed and re-opened). I'd have to try those 5 different settings individually while opening and closing Blender each time to know which of those settings are directly affecting the issue.

Thanks so much for your valuable time in looking into this! That's extremely helpful info.

~Adam

Yep, that's what it was: "Prefer Maximum Performance"! That was the only setting I changed just now, and sure enough, no more stuttering. So I guess the new "power saving" modes must have been added in the newer drivers and that's what broke it. Basically then, when I enabled the screen capture settings in my previous workaround, the GPU must have kicked into the "Prefer Maximum Performance" mode, which "indirectly" solved the stuttering.

Thanks again, Daniel! I guess this could be set to Resolved, then? :-)

On another note, I added Blender.exe as a specified program in the "Program Settings" tab to use maximum performance, rather than leaving it as a Global setting.

It works great! :-)

Im so happy that it works :) :)

Just to note that there is no reason to mark this as resolved, this is not a Blender bug at all, but an NVidia driver bug. Being aware of the workaround is great, though.