Page MenuHome

Segfault on save over current file name - repeatable, not 100%
Closed, ArchivedPublic

Description

System Information
System Info Attached

Blender Version
Broken: 2.77a, 2.78a

Three crash reports attached.

Saving the file without changing the name causes a segfault - this is repeatable on my system with the attached .blend most of the time, however it does not occur with other files (for example I can save over the startup file without issue)
I have older versions of this file which do not seem to cause the issue, however after reverting to one and working for a while the issue seems to reappear.

The mesh and armature are created with ManuelBastioniLab.

Exact steps for others to reproduce the error
Attempt to save the .blend without changing the name.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Cannot reproduce, tried to save at least 20 times in a row, changing bone selection, PoV in 3DView… Steady as a rock here for me.

So guess we'll need more info about how to get it crashing (do you do something specific before saving? etc.)

Can't seem to nail down a specific step to generate the issue - simply continuing editing the mesh for enough time reproduces the issue, also adding/deleting materials, remapping UV projections... all from the same start file. Sorry I can't find more specific detail; it's a very odd problem.

For clarity, the crash never occurs unless I am trying to overwrite the current working file - if I save as some other name it works perfectly.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.

The issue reported can't be reproduced so far, and has been moved to the BF Blender: Unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

Aaron Carlisle (Blendify) closed this task as Archived.
Aaron Carlisle (Blendify) claimed this task.

Time to close this...