Collada Export fails to re-import
Closed, ResolvedPublic


Blender Version
Broken: 2.78a

Exported Collada from Blender does not match original

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Open Attached blend file
Export to Collada (default)
Import into Blender

The animation is different in the blender you imported to.

On the import there appears to be a strange translation added.



I think this may related to T49922, this file includes animation but I think the key point looks same: Blender exports transforms incorrectly (some cases)

I wrote a viewer in opengl and it shows the same incorrect transform on the animation.

Interestingly blender appears to have a correct or at least much more correct animation if the information in the visual scene for the armature is removed

<visual_scene id="Scene" name="Scene">
<node id="Armature" name="Armature" type="NODE">
<translate sid="location">4.92884e-4 -0.01384696 2.569098</translate>

<visual_scene id="Scene" name="Scene">
<node id="Armature" name="Armature" type="NODE">
<translate sid="location">0 0 0</translate>

Gives a much better result.

I am really unclear as to why, and also not really sure how this would impact my viewer to get it to give the same results as the original but figured it was worth mentioning

I will look into this shortly.

Hi, Brenda;

This issue is fixed in master. You may want to double check that the problem is fully solved.

Thanks for reporting this bug

Gaia Clary (gaiaclary) closed this task as Resolved.Feb 16 2018, 5:04 PM