Page MenuHome

[MSVC2015/x86] Crash when rendering with cycles.
Closed, ResolvedPublic

Description

When rendering with cycles (any scene), blender crashes instantly (in release x86 builds only, debug is fine, x64 is fine)

a nullref in beckmann_table_rows seems to be the culprit, problem goes away if i turn int index_slope_x to volatile (feels like a codegen bug, but lack the time to properly investigate).

Bumped into it while running sanity checks on the lib updates from this week, but can replicate the crash with a daily from the buildbot (used blender-2.78-841f3e4-win32-vc14.zip but really doubt it matters much)

Details

Type
Bug

Event Timeline

i would just loike the rendering to start not to take me off the software

is their anyway i could prevent this from happening

Use a different build. Just the experimental 2015 x86 build has this issue.

Bastien Montagne (mont29) triaged this task as Normal priority.

@LazyDodo (LazyDodo) assigning to you since you maintain MSVC2015 afaik? Feel free to merge or close if you consider this as known issue for now, though.

Maybe @Sergey Sharybin (sergey) will also want to have a lok here (if he is not yet aware of the issue)?

Interesting. Are you talking about index_slope_x for loop over random number U1 ?

https://git.blender.org/gitweb/gitweb.cgi/blender.git/blob/HEAD:/intern/cycles/render/shader.cpp#l75
^^ this guy

I have to admit, i have no idea why this solves the crash, nor have I confirmed the resulting table is identical to 'good' build.

Update: With this fix and D2367 applied , x86/2015 passes all of our tests tests.

LazyDodo (LazyDodo) closed this task as Resolved.Apr 25 2017, 10:23 PM