Vertex slide redo problems when clamp is on
Closed, ArchivedPublic

Description

Blender Version
2.78a

Short description of error
If you change Correct UVs parameter in Slider operator it moves with vertex. It is working fine on flat surfaces.

bug plane test.blend

Details

Type
To Do
Dalai Felinto (dfelinto) triaged this task as "Confirmed" priority.Jan 12 2017, 12:46 PM

Correct me if I'm wrong, but the bug you are reporting is:

The new vertex position is discarded when you change the operator (Shift+V) settings after you ran it  (F6).

How to reproduce the bug:

  • Open: bug_vertex_slide.blend
  • Shift +V, drag it to the right
  • Change "Correct UV" (or any other) parameter from the Operator panel (or F6)

Now the vertex "jumps" to the left (not even the original position, but like a flipped x position).

Note, if you draw to the left instead of the right it works fine.

Yes it same bug. Thanks.

The problem is with the "clamp" option. When you start the operator with "clamp" turned off, things work fine. More specifically:

TransDataVertSlideVert.co_link_curr is not reset to zero when we re-do the operator, and not recalculated (calcVertSlideMouseActiveEdges() is only called on mousemove)

Dalai Felinto (dfelinto) closed this task as "Archived".Jan 12 2017, 5:05 PM
Dalai Felinto (dfelinto) claimed this task.

This is a limitation of our system, added to the todo list: https://wiki.blender.org/index.php/Dev:Source/Development/Todo/Tools#Transform

Dalai Felinto (dfelinto) changed the title from "Slide UV correct move vertices" to "Vertex slide redo problems when clamp is on".Jan 12 2017, 5:05 PM
Dalai Felinto (dfelinto) changed Type from Bug to To Do.

Add Comment