Relative Path Issue in windows and linux
Closed, InvalidPublic

Description

System Information
Windows and Linux release Build

Blender Version
Broken: 2.78c
Worked: not tested

Short description of error

Video failed to load if saved from different platform, in this case, I saved the file in windows and try to open in linux machine. The weird thing is the path relative and before-after reloading the video, the path is not change at all.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

I've created the project folder as follows in google drive shared folder:

  • project folder
    • edit
      • edit01.blend
    • footages
      • sequences01.mp4
      • sequences02.mp4
  1. in edit01.blend add strips for both sequences. Make relative and save in windows pc
  2. Open the save file blend in linux pc, and the videos (sequences01.mp4 and sequences02.mp4) are not loaded. In strip input panel, make sure to copy the current path to compare with later.
  3. Try to change the path by pressing the folder icon, select the footages folder. After selecting it, you'll notice the path hasn't change at all but now the video are loaded.

Details

Type
Bug
Dalai Felinto (dfelinto) triaged this task as "Incomplete" priority.May 22 2017, 12:38 PM

Please attach a sample file.

You can reproduce your folder structure but use this footage instead:
http://download.blender.org/peach/trailer/trailer_400p.ogg

So developers can debug/reproduce your issue from your edit01.blend saved on Windows. (don't need to attach the footage, just the blend)

Bastien Montagne (mont29) closed this task as "Invalid".Mon, May 29, 9:55 AM
Bastien Montagne (mont29) claimed this task.

More than a week without reply. Due to the policy of the tracker archiving for until required info/data are provided.