Huge difference in render time between two almost similar frames
Closed, ResolvedPublic

Description

System Information
Windows 7 and Windows 10 (both were used).
GeForce GTX 860M and GeForce GTX 1070 8GB GDDR5 SLI (both were used)

Blender Version
Broken: (2.78c or 2.77 a)

Short description of error
Huge difference in render time between two almost similar frames

Exact steps for others to reproduce the error


Go to my Blend file which contains scene with rigid body objects that are falling on the table and later particles start to emit and explode from those objects. At frame 91 - i am not able to render on GPU ( Error "Nvidia Windows Kernel Mode driver has stopped responding") . But at frame 92 - i am able to render on GPU very fast and with no errors. There are actually many such problematic frames. Frames 91 and 92 - given as good examples.

frame 91 looks like this on my computer -

P.S. There is no reason for that error to appear at frame 91 because frame 92 is almost the same. Also all drivers are up to date and a lot i did to avoid that error. For example i tried to use different versions of Blender (2.78c and 2.77a), i tried to reinstall nvidia drivers and CUDA toolkit, used different versions of nvidia drivers. Tried to reinstall Windows7. I tried it on windows 7 and windows 10. Tried to render on different laptops. I also made some advised on "Microsoft Support "changes to the registry in "TdrDelay FILE" and also changed Nvidia driver settings where i enabled "prefer maximum performance" and switched off "VSync". I even tried to simplify the scene by removing all subdivision surface modifiers on a chalk pieces and remove textures from the table. Problem persists on many frames. One of them - frame 91. As a contrast - frame 92 for example, where no problems appeared.

Details

Type
Bug

Hi.
Whenever you see this kind of strange problems related to slowness in certain frames or frame intervals, you should see if this is related to Motion Blur enabled.
I have seen other times Motion Blur cause these kind of problems. I do not know if this is due to a bug or just it is one of those known problems that usually have Motion Blur in Blender.

Viktor (Silverland) added a comment.EditedMar 17 2017, 4:17 PM

Hi. But the motion blur is presented on a frame 92 as well,but i can successfully render that frame, so no problems there. Thats why i reported it. Because its not normal when you have all frames look similar but render time for one frame - 10 hours, for frame next to it - 8 minutes

Yes, it is. That's what I mean when I say I've seen this kind of problem before. So let's wait for what cycles developers say about this.

If its motion blur was causing those problems then i think it would be a big issue because a lot of people using motion blur to render animations and also it means it would be a lot of such bug reports and probably it would be fixed by now. But yes, lets wait what developers will say.

Aaron Carlisle (Blendify) triaged this task as Incomplete priority.Apr 15 2017, 9:44 PM

Please try with a build from builder.blender.org/download

Cannot check. This Blender built crushes all the time as soon as i opening that my file all if i very quickly open that file and press F12, it renders for a few seconds and then crushes again.

Aaron Carlisle (Blendify) closed this task as Resolved.May 16 2017, 9:03 PM
Aaron Carlisle (Blendify) claimed this task.

Considering the slowdown is most likely from motion blur, which has been optimized for 2.79 and I can open the blend-file without it crashing I am going to close this report.