Page MenuHome

Generated movie strip proxy files are never used
Closed, InvalidPublic

Description

Blender generates proxy files, but when I choose to use them for display, it shows me scaled-down original footage, which is very slow.

This issue bugs me for a years now, and recently it got so bad I'm completely unable to use Proxies since about a month.

I tested with 2.71, 2.78 and 2.78c. No mater how many times I rebuild the proxy data, it's never used.

Event Timeline

Hmm, that's a strange one... can you provide a set of files to reproduce? I think proxies generally work for most users, so I guess we should find out what's different in your case.

I'll try to produce a small sample project for testing soon.

EDIT:

Argh! Now that I have finally reported this problem, I can't reproduce it!

I'll bump this when I manage to reproduce the issue. I have some existing projects, but they use a few GiB of video files, so that's a problem.

Aaron Carlisle (Blendify) lowered the priority of this task from 90 to Low.Apr 11 2017, 12:45 AM

The issue reported can't be reproduced so far, and has been moved to the BF Blender: Unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.

Ok, I have one project that manifests this, but is uses a few GBs of video files, I'll see if just on of these will do in a project. So I can upload it for testing.

I've done some testing regarding a different issue, and I've found out that often the Proxy adn TC files in BL_Proxy/Clip_Name/ folder are deleted for some reason, so it seems like I've done building Proxy but then the files are gone and I can't use them.

Maybe this is related. I'll try assesing if Blender spits some console messages when this happens.

Can someone confirm that the bug still exists

Not quite, I have done some triaging, and assumed, that user may started to generate proxies for his files and process has been interrupted. In such case all generated proxies would be deleted. Not only those interupted and pending.
So technically this may be a feature request, but very reasonable.

By looking at code solution may be not quite trivial as it seems to be, because job is done in stages for all files, so probably some flag has to be added to queue items. Not quite sure at this point

Eitan (EitanSomething) claimed this task.EditedNov 29 2019, 5:31 AM

I will look into it, but I think the problem is that they are being deleted when the proxy process is interrupted.If this is the case can you add a todo on the video sequencer list and I will close the report.

Eitan (EitanSomething) closed this task as Invalid.EditedDec 31 2019, 2:24 PM
Eitan (EitanSomething) claimed this task.

I’m closing this because I can’t reproduce please remove from T64682