Game engine crashes
Closed, ArchivedPublic

Description

System Information
windows 8.1, amd r9 280, radeon driver 16.7.3

Blender Version
Blender 2.78
Worked: 2.77

The standalone game engine crashes in various circumstances, but not in version 2.77

Either use the quit game option in the game actuator, or get lucky and have it crash randomly when using various physical objects. The game simply closes saying "blender has stopped working." (I spent 4 hours trying to recreate the crash, but all I know is it happens when there are a lot of objects with a variety of physics types in a small area. I can't even guarantee that this is why. I can record this happening though and upload it to YouTube if it helps, though.)

Details

Type
Bug
Aaron Carlisle (Blendify) triaged this task as "Incomplete" priority.

Please add a blend-file that crashes.

Leanardoe (Leanardoe) added a comment.EditedApr 9 2017, 1:08 AM

I can't seem to simplify the blend file and still retain the crash. Sorry about that. Here is a download for the entire game. The crash occurs after walking through a door. It doesn't crash on blender 2.77. The scene that the main game is in is "Scene."
https://www.dropbox.com/s/brwuujvr0udpqvy/game.zip?dl=0

The crash doesn't occur every time. Usually about 40% of the time after going through a door.

Aaron Carlisle (Blendify) raised the priority of this task from "Incomplete" to "Needs Triage".Apr 9 2017, 3:59 PM
Dalai Felinto (dfelinto) triaged this task as "Incomplete" priority.May 15 2017, 2:33 PM

This doesn't happen on Linux. And it would be really time consuming to work in a non isolated file. Can you can build a debug version of Blender and paste the backtrace of the crash when running from MSVC?

This doesn't happen on Linux. And it would be really time consuming to work in a non isolated file. Can you can build a debug version of Blender and paste the backtrace of the crash when running from MSVC?

Where can I get a debug version? Also how would I run from MSVC?

I can try to test for you tomorrow. I think the comment was more directed towards me.

I do not think we can reproduce unless we have a 100% reproducible case.

Bastien Montagne (mont29) closed this task as "Archived".Jun 6 2017, 6:20 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply. Due to the policy of the tracker archiving for until required info/data are provided.