Crash when applying materials to curves
Closed, ArchivedPublic

Description

blender-2.78-a85f457-win64 Win 10

I have created bezier curve and in edit mode duplicated it for 3 times and then rearranged the vertices.

When applying the materials in cycles, Blender stopped to respond and crashed.
This happens randomly. When I have done that second time Blender did not crash.

But it did crash after awhile when repeating the same step.

So, it's not reproducable every time.

This is just a report. I can not provide more useful details.

Details

Type
Bug
soulfire (vejn) updated the task description. (Show Details)
Sergey Sharybin (sergey) triaged this task as Incomplete priority.Apr 28 2017, 2:12 PM

It is important to provide simple .blend file which demonstrates the issue. If the issue happens sometimes, try to isolate variables which affects on the crash.

It is important to provide simple .blend file which demonstrates the issue. If the issue happens sometimes, try to isolate variables which affects on the crash.

It's just one bezier curve and then duplicated in edit mode # number of times.
It crashed this way:

  1. I applied materials to the curve
  2. click on viewport shading rendered
  3. crash

Blend file didn't save.

I tried repeate steps again but it didn't crash.

  1. not much activity
  2. no blend file provided
  3. user try to recreate but it DIDN'T crash.

Closing for now, however:

  1. if you managed to re-create again the crash, see if crash log generated:

Blender crash log
https://docs.blender.org/manual/en/dev/troubleshooting/crash.html

  1. If you want to try re-create the crash again, you may want to try this:

It also worth running Blender with --debug-cycles command line argument to make prints much more verbose to see where exactly things stuck.

Fable Fox (fablefox) closed this task as Invalid.May 22 2017, 4:02 AM
Fable Fox (fablefox) claimed this task.
Alexander (deepforest) claimed this task.EditedOct 17 2018, 1:16 AM
Alexander (deepforest) reopened this task as Open.

Confirmed. Blender 2.79b, Win7x64

  1. Solid - viewport shading
  2. several times duplicate curves
  3. add Shape - Full, Fill Deformed, Depth, Extrude, Resolution
  4. apply material
  5. Crash

video https://youtu.be/Uv1hnFN_zqI
blend file, log https://www.mediafire.com/file/8z3390gi0pv8fne/crash-curve-material.zip/file
screenshot https://imgur.com/a/FgO1umY

can't reproduce, anyway you can shorten the reproduction from 'do random stuff for nearly 2 minutes' to

1 open file
2 click add new material
3 crash.

can't reproduce, anyway you can shorten the reproduction from 'do random stuff for nearly 2 minutes' to

1 open file
2 click add new material
3 crash.

Do you see my video? I can add more video with reproduce this bug.

yes, you messed about for 2 minutes, which is a terrible way of reproducing a bug, we need concrete steps to reproduce a bug, not a minutes long video.

Why you so angry? Look another video. To reproduce, needed duplicate curve 2-3 times.
https://youtu.be/dOEPABg2DS4

Why so angry? you're not listening.

US: Please do not post nearly 2 minute long videos, video's are not bug reports, please post proper steps to reproduce the issue.
you: here's nearly 3 minute video..

Who are you? Developer? My last video its clear to understand what steps needed to reproduce the bug.

Please don't reopen old reports, but create a new one with all the required information.
https://developer.blender.org/maniphest/task/edit/form/1/

I can't reproduce the bug from the video either. So please save the .blend file at the step right before it crashes, and then attach it. This way we can determine if it's an issue with the steps not being redone correctly, or perhaps something else like a issue specific to your graphics card or user preferences.