Page MenuHome

Lagging with Blender 2.78 on Mac OS Sierra
Closed, ArchivedPublic

Description

System Information
-MAC OS Sierra ( Imac 27" 2013 )
-Intel core I7 3,5 Ghz

Operating system and graphics card

  • MAC OS Sierra 10.12.4

-NVIDIA GetForce GTX 780 4096 Mo

Blender Version
Blender 2.78C

Short description of error

  • Blender 2.78 is lagging several seconds when I select a mesh with a resolution higher than 1 million faces in the viewport. It was not the case with my previous version of Blender ( 2.76 ). I have another computer ( Mc Book Pro ), and I tried to install Blender 2.78 on this 2nd machine => same lagging bug with mesh higher than 1 million faces.

Exact steps for others to reproduce the error

  • Create a sphere
  • Create a cube
  • Use a multiresolution modifier and increase the resolution of the cube up to 1 million faces.
  • Select the sphere and after try to select the cube ... and if you are as me you will see the lagging bug I have ( once again :I have this problem only on Blender 2.78. Blender 2.76 works perfectly well on my machines ).

Thank you for your help
Regards
Sébastien

Details

Type
Bug

Event Timeline

How much RAM do you have?
I have 2011 27" Mac with 32 GB RAM and no lagging on 2 million faces.
Slight lag when initiating screen recording though.
https://youtu.be/ahlO4KkAeVg

Hello,

Thank you to share this video.

I have 16 GB RAM. So your computer is a little bit better than mine.

But I have no lag with previous Blender 2.76 ( I have lag only with Blender 2.78 ), so I think the RAM is not responsible.

I notice you have an AMD video card, my 2 computers ( Imac and Mac book pro ) have NVIDIA cards. I don't know if there is something wrong between NVDIA for Mac and the latest version of Blender ?

Sébastien

It might be related to a change we made in 2.77 — always use VBOs to draw objects. @Small Sébastien (Conique2001) your graphics card has plenty of VRAM so should be able to handle large poly counts. So hmmm....

Does 2.76 b also lag when you enable User Prefs | System | VBOs? What about 2.77? That would confirm this cause or tell us to look elsewhere.

Also try "OpenGL Occlusion Queries" in User Prefs | System | Selection.

Hello,

Yes, the lagging problem is the same with Blender 2.77 when I try to select a mesh higher than 1 million faces.

With Blender 2.76 with VBO enabled => I can reproduce the lagging problem => so you're right : the enabling of VBO seems probably to be the root cause.

I try to set "open GL Occlusion queries" in Blender 2.78 ( and also 2.77 ) as you recommend ... and now it's works pretty well ! ( the lagging bug has clearly disappeared )

Thank you very much for your help. I'm happy to be able to use now the latest version of Blender :-)

Sébastien

Sergey Sharybin (sergey) closed this task as Archived.
Sergey Sharybin (sergey) claimed this task.

Thanks for the report, but the seleciton code and viewport drawing is changing completely in blender2.8 branch.

Better to move forces there finishing the 2.8 project rather than dig into issues in master branch on specific configuration, especially since there is a workaorund for now.