Page MenuHome

Audio Pan doesn't function in the VSE if import audio has different Sample Rate than User Pref audio sample rate.
Closed, InvalidPublic

Description

System Information
Windows 10 1703
Intel i5 3570K 3.4Ghz
16GB RAM
Nvidia GTX 1060 6GB

Blender Version
Broken: 2.78c

Short description of error
Audio Pan doesn't function at all in the VSE if imported video has different sample rate than User Preferences.
I've imported Mono audio.
I've selected the Mono checkmark option.
I switch the user preferences audio to Mono.
I've selected Mono in the audio section of the Scene Tab.
I even tried caching the audio.
No Luck.

Exact steps for others to reproduce the error

  1. Import an MP4 video into the VSE that has 48 kHz audio sample rate
  2. set the User preferences to to have a audio sample rate of 44.1kHz
  3. Right click on Audio to select.
  4. Press N to show strip options
  5. Pan the Audio from -1 to +1

Details

Type
Bug

Event Timeline

Mikeycal Meyers (mikeycal) renamed this task from Audio Pan doesn't function at all in the VSE. to Audio Pan doesn't function in the VSE if import audio has different Sample Rate than User Pref audio sample rate..

I think this may have been a false alarm.
You can try it just to make sure, but everything seems to be working now.
I'm starting to think it may have been an issue with my computer's Audio that just needed a reboot.

Okay, then I'm closing this.

FYI about the things you tried:

You need one of these to make it work. Both also works, but is not necessary:

  • I've imported Mono audio.
  • I've selected the Mono checkmark option.

If the output is mono however, how should there be panning? You cannot pan the output to different speakers when there is only one. You can't have these:

  • I switch the user preferences audio to Mono.
  • I've selected Mono in the audio section of the Scene Tab.

These don't matter:

  • Audio Pan doesn't function at all in the VSE if imported video has different sample rate than User Preferences.
  • I even tried caching the audio.

Cheers

Joerg Mueller (nexyon) closed this task as Invalid.May 22 2017, 9:29 AM