Add to Pose-Library doesn't work while tweaking strips in NLA Editor
Closed, InvalidPublic

Description

System Information
Windows 7 64-bit GTX 770

Blender Version
Broken: 2.78 Stable (e92f235283) and 2.78 Daily (7b25ffb)

Short description of error
While trying to add poses to the Pose Library, if you are currently in tweak mode for an action strip, an empty pose will be added to the library instead of the rig's actual/current pose.

Exact steps for others to reproduce the error
Select an action strip >> Press tab (tweak action strip)
Add Pose to Pose Library >> change pose / stop tweaking and (go to a different frame)

Loading the pose will do nothing


Repeat steps, without being in tweak mode, and it will work correctly.
While setting up for this report, at one point, it still worked in tweak mode but every prior/subsequent try resulted the same.
It's reproducible, but I can't find any other cause aside from action-strip tweak.

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as "Normal" priority.

Not sure how much we could support that… @Joshua Leung (aligorith) another one for you to check I guess?

Joshua Leung (aligorith) closed this task as "Invalid".Jul 11 2017, 3:26 PM

Looks like you've just got a messed-up Pose Library action.

Looking at it, it's got heaps of random keyframes in there, but no pose markers. Therefore, any attempts to do anything with it will fail.