Page MenuHome

FBX: Exported rigged geometry weirdly distorted, looks eaten away at bone positions
Open, NormalPublic

Description

Blender Version
Broken: 2.78

Short description of error
I'm having a strange problem of certain bones in my rig causing a weird distortion when exported to .fbx and imported into Unity. Basically, the problem bones are causing the mesh to look eaten away:

Note the cheek area where it looks punched in instead of being smooth. I've done many tests, but can't figure out what's happening. Looks to be a bug. All the other bones are fine except for 3 problem bones.

Problem file attached.

Details

Type
Bug

Event Timeline

We cannot do anything without an example. Please attach the file you said you had attached.
Also, be sure to test with the latest version of Blender, preferrably a daily build from https://builder.blender.org/download/.

Ah, sorry, it was late, haha. Here's the file:

Tested with the latest build.. which may be even buggier as the exports don't appear in Unity's viewport when brought into a scene (i.e. geometry's invisible and I only see the pivot point, happens also with just vanilla Suzanne).
However, in the preview window, I'm able to see the geometry, and it has the same "eaten away" distortion.

I can open the file, but I don't see any of the distortion at all with a buildbot build of version rB0021268.

Bastien Montagne (mont29) edited projects, added Addons, Import/Export; removed BF Blender.
Bastien Montagne (mont29) renamed this task from Exported rigged geometry weirdly distorted, looks eaten away at bone positions to FBX: Exported rigged geometry weirdly distorted, looks eaten away at bone positions.

There should be as I've also confirmed this with a co-worker.

Did you export a .fbx out of Blender and tried importing into Unity? You could also try Autodesk's FBX Review as I've found that shows the distortion as well.
Strangely enough, importing the .fbx back into Blender itself doesn't show the distortion, but the distortion doesn't only show up in Unity, which makes me suspect it's not Unity's problem.

Sergey Sharybin (sergey) triaged this task as Normal priority.May 29 2017, 5:33 PM
Bastien Montagne (mont29) lowered the priority of this task from Normal to Incomplete.Jul 20 2017, 11:11 AM

I really need something simpler to investigate that whole rig with all the control bones, drivers, constraints etc. is really way too complex. It’s actually really complex for exporter even, for start. Might be related to T52039 actually, but kind of hard to say here…

Bastien Montagne (mont29) closed this task as Archived.Aug 1 2017, 10:51 PM

More than a week without reply. Due to the policy of the tracker archiving for until required info/data are provided.

Oh, forgot to respond to this. The exporting itself works just fine for me.

I originally included the whole rig because I don't know what's causing the problem. Not that I do now, but through trial and error, I simplified the setup somewhat to help you guys narrow down the problem.

Again, to reiterate, you don't see the problem in Blender, but if you import the exported file into some other programs (e.g. Unity), you'll see it.

Bastien Montagne (mont29) raised the priority of this task from Incomplete to Normal.

Thanks, will check.