Collision drastically affects shading in BI
Open, ConfirmedPublic

Description

System Information
Win7 64

Blender Version
Broken: 2.78a

Short description of error
Render produces different shading for two objects which are sharing same mesh data. But one object has got Collision modifer, another - doesn't.

Exact steps for others to reproduce the error
I know, that you are not developing BI anymore, but anyway. Render file, then check/uncheck Switch node checkbox to see the difference.

Details

Type
Bug
Bastien Montagne (mont29) closed this task as "Invalid".Jun 1 2017, 9:13 AM
Bastien Montagne (mont29) claimed this task.

That’s no bug, afaik no render engine survives well to coplanar faces… Numerical imprecision just makes it impossible to decide which face is visible for which pixel, generates auto-shadowing, etc.

Sorry, but I don't understand how the same mesh has different shading due to collision modifier, which does nothing in this case. Also Cycles produce the same shading with or without Collision modifier.

Bastien Montagne (mont29) reopened this task as "Open".Jun 1 2017, 2:30 PM
Bastien Montagne (mont29) triaged this task as "Confirmed" priority.

Eeeeek! Ok, totally completely misunderstood the report here, sorry!

Now, issue here is with triangulation, looks like collision modifier can affect base mesh in some cases, yuck. :/

Tried to understand what’s going on here for quite some time now, and… am running out of idea.

Issue is not with Collision modifier, that one does not affect DM data at all - and anyway, tried emptying its evaluation function and changed nothing.

So am assuming issue is somewhere in modifiers stack evaluation itself (aka mesh_calc_modifiers()), but could not pinpoint any differences here… Imho it's either tessellating issue, or poly normal issue, but both seem to be handled exactly the same way in both cases. @Campbell Barton (campbellbarton) may have more ideas/insight?