Page MenuHome

Cycles denoising; Firefly/Highlight processing leads to pixels with negative values, values of -1.#INDO
Closed, ArchivedPublic

Description

System Information
Win10 64 bit; 24 gigs RAM; third-gen i7 CPU; AMD 7xxx GPU (Crimson ReLive drivers)
CPU Rendering

Blender Version
Broken: Hash c73206a
Worked: Never

Short description of error
When the denoiser processes scenes containing firefly-prone materials and bright highlights, it can lead to results filled with black pixels (some with negative values, others with values of -1.#INDO). Increasing the samples helps to reduce the issue of fireflies going black, but not with highlights that are small and bright.

Exact steps for others to reproduce the error
Open the .blend file, render the scene, and examine the values of the many black pixels on top of Suzanne.

.blend

Details

Type
Bug

Event Timeline

Adam Friesen (ace_dragon) renamed this task from Cycles denoising; Firefly processing leads to pixels with negative values, values of -1.#INDO to Cycles denoising; Firefly/Highlight processing leads to pixels with negative values, values of -1.#INDO.

Okay, there definitely is a major regression in overall quality due to one or both of these commits
https://lists.blender.org/pipermail/bf-blender-cvs/2017-June/097346.html
https://lists.blender.org/pipermail/bf-blender-cvs/2017-June/097384.html

Illustration

Before the commits (left image), fireflies just disappeared with no issue, highlight processing might've left a black pixel here and there, but their values were just slightly negative instead of INDO.
After the commits (right image), a number of fireflies and highlights now just go black instead of going away or being left alone. The quality issues that were resolved were surpassed greatly by the number that were introduced (and the regression affects every scene I might add, bright pixels aren't needed to trigger it).

Lukas Stockner (lukasstockner97) closed this task as Archived.

Okay, this is somewhat improved with rB558bea2. I'll look into better handling in the future, but we're really close to a release and fixing the underlying issues will be really tricky (if it's even possible)...

I'll close this for now, but I'll keep the file for further tests.

(Sorry for the copy-paste from other reports, these are all related issues).