Page MenuHome

Broken UI after creating new file in 2.79 test and daily builds
Closed, ResolvedPublic

Description

System Information
Windows 10x64 Home Ru Version 1607 Build 14393.639 + latest autoupdates
NVIDIA GeForce GTX 970 with 378.66 NVIDIA drivers (latest)
Intel Core i7-4790K

Blender Version
Broken:
2.79 testbuild x64 e0bc5b5
2.79 daily build x64 c2d285f
Worked:
2.78c x64 e92f235283

Short description of error
Creating new file leads to UI bug:

  1. all windows titles becomes hidden
  2. outliner windows scale is changed

UI can be fixed by main window resizing.

Exact steps for others to reproduce the error
Create new file by "File / New" menu command.

Event Timeline

I can recreate the issue on Win7 build ed6d88f by renaming the userpref.blend file in the config folder so Blender cannot load it.
Parts of the UI will be blank until the window is resized with both loading the Default Template and a New File.

In this case, it is possible that the userpref blend is missing or that is somehow got corrupted / incompatible with the current builds.

mathieu menuet (bliblubli) triaged this task as Confirmed, Medium priority.

I can also confirm the bug.

Brecht Van Lommel (brecht) reopened this task as Open.

I've committed a fix which solves the case described by @Vuk Gardašević (lijenstina) on macOS, when there is no userpref.blend.

Can someone confirm if this solves the bug on Windows? It's not clear to me if it only happens without a userpref.blend or if there's another issue.

tested on windows with a missing userpref.blend , problem is solved,

Brecht Van Lommel (brecht) closed this task as Resolved.Jul 3 2017, 4:12 AM
Brecht Van Lommel (brecht) claimed this task.

Thanks, I'll consider it fixed then.

This task probably needs to be reopened because I tried the latest build today (blender-2.78-fee7f68-win64) and still see the same behavior when userpref.blend is not present. (Using windows 7 64-bit)

Also no matter if userpref.blend is there or not, the menu command "File -> Load Factory Settings" always show the same error as shown in original reporters attached gif.

Is it possible that when userpref.blend is not present "File -> New" reverts to loading factory settings which is broken somehow.

I can confirm the bug is still there on windows. Two cases: user pref is there and only "load factory settings" will mess up. Or there is no userpref and then file->new and "load factory settings" will messup the UI.

I can also confirm "File -> Load Factory Settings" breaks the UI.
Interestingly, it seems resizing the window or causing a DPI change event or even moving the window restores the UI to the correct state.