Page MenuHome

Node Defocus, Artifacts - ragged blur edges
Closed, ArchivedPublic

Description

System Information
ubuntu 14.04 lte / gtx 970

Blender Version
Broken: 2.78c, 2.79

Short description of error
Artifacts - ragged blur edges

Exact steps for others to reproduce the error

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Normal priority.

I think you are merely hitting the limits of post-processing DoF effect here… 'jagging' is actually merely blur disappearing at points where very out-of-focus pixels are neighbors of perfectly on focus plane ones, don't think post-processing can handle that situation better. Would be TODO anyway, imho, not a bug. @Sergey Sharybin (sergey) shall know more about that, though?

Sergey Sharybin (sergey) closed this task as Archived.Jul 5 2017, 3:58 PM

This is indeed a limitation of current Defocus node. The way it works is it calculates blur radius based on image depth and then applies variable size Bokeh blur. Such approach can not deal with such cases.

Improvements to algorithm are possible, but those happens outside of the bug tracker.

So thanks for the report, but it's not considered a bug.

And can you find out if this algorithm will improve? If the post process did DOF as well as the cycles, it would be very noticeable, but for the time being it is practically not applicable.