Synchronization between Video and UI/Image editor.
Closed, ArchivedPublic

Description

System imformation :
Computer ASUS Desktop PC P30AD
Graphics card: VGA compatible controller: Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller (rev 06)
Processor 4 Intel Core i3-4160 CPU @ 3,60 Ghz
Memory : 3914 MB
OS : Ubuntu 16.04.2 LTS

Blender version: Blender 2.78 c (downloaded from Ubuntu Software centre)

Description of the error:
The problem I describe here is a problem I have with all the videos I shot with my Panasonic Camcorder HC-VX870.
In the video I used, I wanted to blur a ship floating on the river Seine. Fro some reasons, I cannot get full synchronization between the Video window (right side of my screen) and the
U/I Image editor (left side of my screen).

Specifications s of the video :
Duration : 1 minute 24 seconds
Container : Quicktime
Video :
Dimensions : 3840 x 2160
Codec : H.264 (High profile)
Frame rate : 25 fps
Bit rate : 61128 kbps
Audio :
Codec : MPEG4-AAC
Channels : Stereo
Sample rate : 48000 Hz
Bit rate : 256 kbps
Media details
Demuxer : lavfpref

What I did,
For each step, only what I describe is is happening in the mentioned window (e.g. step 4: things are happening in the Upper left-side window).

Step 1 : I add the video. It appears in the Upper-right side window. OK.


Step 2 : I open the UV Image Editor in the Upper-left side window . OK.
Step 3 : I create my mask (upper-ledt side window). I call it Blur_01. OK.
Step 4 : In the Upper-left side window, I open the video. It appears. OK. No sinc yet.

Step 5 : In the Upper-left side window, I select View/Properties, in order to sync the left side and right side.
Step 6 : In the Upper-left side window, I now tick the Match movie length and Auto Refresh boxes… and the video disappears (or, with some other videos I tried with, the video freezes on some frame).

As a work-around, I converted another of one of my mp4 videos (4692 frames) into a sequence of 4692 PNG images. I managed to get full sync between the upper-right and left windows and to blur the areas I wanted to blur (i.e; Create mask, applying absolute mode, and make it move around and follow the movements of the object I wanted to blur.)

I also tried on Blender 2,76. I managed to move my mask around in the UV Image Editor, then I ended up with two cases :

  • If I start from image 1 (say image 1 to image 50), everything seems to work fine and I manage to get full sync (i.e. the mask moves around nicely in both windows).
  • If I start from another image (say image 51 to 100), then I cannot get the sync and, while the mask moves around in the Upper-left side window, it stays stuck at image 51 in the Upper -right side window.

Thanking you for your attention and your efforts.

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as "Incomplete" priority.Jul 19 2017, 10:46 AM

Difficult to help really without a simple .blend file to reproduce the issue, but two things to check:

  1. Did you enabled AV-sync synchronization mode in TimeLine editor's header bar?
  2. Did you generate valid timecode for your video?

Thanks for your email.

  • Did you enabled AV-sync synchronization mode in TimeLine editor's header bar?**

Yes

  • Did you generate valid timecode for your video?**

I import (add) my video.
I go to Properties. I tick the Proxy/Timecode box. I tick 50%. Then I go to the Strip menu and select Rebuild Proxy and Timecode indices and wait until the porcess is complete.
Then in the Upper right side window, I select View and select Proxy size 50% in the Proxy Render size.
In the Upper left side window, I select the UV/Image editor. I open my video. I select View, click on Properties and tick the Match Movie Length and Auto Refresh Boxes. In this window, my video freezes on the last frame, (while in the right side video, frames are moving nicely).

I hope this assists. Thanks again.

Hmmm, afaik by default the Not TC In Use option is set for timecode, which means you are not using it. Typically, you’ll want to try with Record Run No Gaps option (same panel, below the proxy settings). Then rebuild proxies/timecodes, and check if issue is still there?

Indeed, I did not notice this box.
I tried again with several of my videos. This time, I manage to get a consistent behaviour (meaning that I always got the same result irrespective of the video I picked up).

What I did
I import (add) my video. It appears in the Upper Right side window.
I go to Properties. I tick the Proxy/Timecode box. I tick 50%. I scroll down a bit, and in the Time code box, I select Record Run No Gaps
Then I go to the Strip menu and select Rebuild Proxy and Timecode indices and wait until the process is complete.
Then in the Upper right side window, I select View and select Proxy size 50% in the Proxy Render size list.
In the Upper left side window, I select the UV/Image editor. I open my video. I select View, click on Properties and tick the Match Movie Length and Auto Refresh Boxes. In this window, my video freezes on the last frame, precisely when I tick the Match Movie Length box, (while in the right side video, frames are moving nicely).

So, still no luck. Thanks for your help.

Bastien Montagne (mont29) closed this task as "Archived".Aug 8 2017, 4:22 PM
Bastien Montagne (mont29) claimed this task.

Hmmpff… fact is, Image editor is not really designed to play videos, it does not even use proxies afaik. You should rather try to Clip Editor if you need an extra viewer for some reason, and set there the proxy & timecode settings just like in the VSE. Then (obviously!) stop and start playback again.

Anyway, I still cannot reproduce any issue here, would suspect yours is just using a rather heavy video, which the ImageEditor cannot handle correctly in realtime. Will close for now, we can always reopen if a reproducible case is provided (and it is indeed a bug, and not a mere stalling-due-to-lack-of-power issue).