Page MenuHome

Loss of linked character pose when character not found
Closed, ArchivedPublic

Description

System Information
Win 8.1x64, 3x gtx580

Blender Version
2.79t1

Short description of error
When opening a file containing linked characters, if character's files aren't available at moment, are moved elsewhere etc., their local poses become irrecoverable regardless if the character is reloaded later or their paths are changed to existing ones.

This creates a situation of irrecoverable data when moved project's original paths cannot exist.

Exact steps for others to reproduce the error

  • Copy attached files to a single folder
  • Open "character-scene.blend" -> Character's hands are risen up (local proxy is posed)
  • Temporarily rename or move "character.blend"
  • Reload "character-scene.blend" -> Character doesn't show up
  • Rename/move "character.blend" back
  • Reload the character from the outliner
  • Character's local pose is not there anymore.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) closed this task as Archived.Jul 19 2017, 9:43 AM
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but don’t think we can do anything about that currently, proxy code and design is already a real problem to handle, and is due to be replaced by static override at some point in 2.8 series, so trying to hack around that is not really planned right now.

Also, workaround here shall be to actually close and re-open main file once you have your library one available at expected path again, without saving it in-between…