Page MenuHome

Black objects in Eevee
Closed, ArchivedPublic

Description

System Information
Ubuntu 16.04
Geforce GTS 250 (driver: 340.102)
OpenGL version 3.3

Blender Version
Broken: 2.8 9a5d06cdd54 ac76a3caba 2ad524bc83

Short description of error
In Eevee, any lamp won't light up an object at all if the lamp's shadow is turned on (resulting in black objects). Here are the error messages when Blender opens:


Screens:

Also I'm not sure whether this is related or should be a different report but irradiance volumes will be dark red for a few seconds and then disappear. Also reflection cube maps are not working at all.

Exact steps for others to reproduce the error
Open Blender on factory settings or this blend:

Details

Type
Bug

Event Timeline

Vuk Gardašević (lijenstina) closed this task as Archived.

Thank you for the report, but 2.8 is currently under heavy development, and we are not taking bugs from end users yet.
Keep watching for updates at https://builder.blender.org/download/ to see if your issue got resolved.

For the time being, closing this report.

OK, but it would be good to know in advance whether there will be additional GPU requirements for 2.8 (apart from OpenGL version) since the GTS 250 is one of the earliest OpenGL 3.3 GPUs and I thought that might have something to do with it.

If you run blender with --debug it should give you a clue of why it failed (it shows which if any shader failed, of if it was memory, ...)

Here's the output for --debug and --debug-gpu, using e0ce01c3b15


Yes, this is a driver/hardware specific problem. (aka it works on my Linux with Mesa).
After the core of 2.8 is ready we will then ask everyone to update their drivers and only then we will afford to spend time debugging those hardware/system specific issues.

I thought I should let you know this problem still exists in latest builds and latest Nvidia driver (340.107). It doesn't happen with the sun lamp though, which works fine. Setting the shadows to VSM cube size 128 causes some glitched shadows which look like some of Blender's icons, like in these screenshots using an area lamp:

As for the last part of the original report, light probes now work ok except crashing sometimes occurs when baking indirect lighting with this output:

X Error of failed request:  GLXBadContext
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  83116
  Current serial number in output stream:  83116