Page MenuHome

Principled BSDF not available in Node Menu: Shift+A then Shader. Not in menu
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card
Intel Core i7 6700HQ. 16Gb
Win 10. V1607
GTX 960M - 4GB

Blender Version
Broken: 2.79 RC 5e9132b
Worked: N/A

Short description of error
Principled BSDF not available in Node Menu: Shift+A then Shader. Not in menu
Accessible thru the Materials pannel (only ?).

Exact steps for others to reproduce the error

  1. Select Start Cube.
  2. Change to Cycles Renderer
  3. In pannel. Material Tab. New.
  4. Open Node editor Window.
  5. Shift + A. Shader. ----Principled not in Menu---

Details

Type
Bug

Event Timeline

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.Aug 9 2017, 10:53 AM

I can not confirm this. The Principled BSDF is in Add ->Shader -> Principled BSDF menu. See the screenshot:

.

Make sure you've downloaded proper build and fully unpacked it.

Here is my screen shot:

Make sure you've downloaded proper build (JP- Yes) and fully unpacked it (JP - Yes).
Note that the Shaders are not sorted in Alphabetical order in my screen.

This has been the case for me since downloading prior builds (including blender-2.79-testbuild2-windows64)

Please show your system-info.txt generated by Help -> Save System Info (as an attachment).

Don't see anything obviously wrong, also tested with some addons which are enabled on your side by are disabled by default.

Please try one more thing: start blender form command line (cmd.exe) with --factory-startup argument and see if that changes your menu.

This solves the problem.
Something in my user pref file seems to trigger the issue.... (for your reference I have attached a copy).

I will look into deactivating the changes made to try to identify the issue. If u see anything obvious let me know.

Thanks,
Jean P.

My guess would be to try using newer blend4web addon. I only managed to download 17.6, while your's is 16.12.1. They do something with the menu, so maybe some fix was done from their side.

Sure enough deactivating b4W resolved the issue.
Thanks for your help and sorry for the non-issue....

Sergey Sharybin (sergey) closed this task as Resolved.Aug 9 2017, 3:13 PM
Sergey Sharybin (sergey) claimed this task.

That's better to investigate bug and found that it's not from Blender side than to have real bug in Blender.

Thanks for the report, closing it as Resolved now!