Normal map bugs in Blender Cycles
Closed, ArchivedPublic

Description

Blender 2.79 build from august 13th.

I have create a normal map in 32 bit Float and saved it in Linear color space in PNG 16 bit. When i use it in Blender Render it works correctly (both Blender render and Cycles have the texture set in Linear mode, non-color does the same).

If i use the same texture in Cycles it bugs:

Here is the node setup of the normal map in Cycles:

Here is my blend file with the textures, enable Use node to switch to the Cycles shader:

Details

Type
Bug
Sergey Sharybin (sergey) closed this task as Archived.Aug 14 2017, 3:14 PM
Sergey Sharybin (sergey) claimed this task.

This doesn't seem to be normal map bug at all. it is just different lighting, caused by different default strength of lights, and different behavior of light models. Using bigger area lights makes mesh being nice smoothly shaded in Cycles. This issue you can see with default diffuse material even.

So thanks for the report, but there just seems to be nothing wrong with normal map.

If i use a mesh with an emissive i still have weird lines everywhere that doesn't appear with Blender render: