Page MenuHome

Selection tools work badly with zoom outed viewport
Closed, ArchivedPublic

Description

System Information
Win7 64 bit, ATI HD4670

Blender Version
Broken: 2.78c

Short description of error
When zooming out mesh with mouse scroll wheel, you get mesh density so tight, that selection tools fail to work.
It is very inconvenient in cases when you create lots of screen menus, and you forced to zoom out 3D scene to see it completely, but do not want to select back faces such as in wireframe mode.

Exact steps for others to reproduce the error
Open file
Border select (B) whole mesh -> every face is selected
Scroll mouse wheel to max zoom out and try to border select -> fail

When selection is in vertex/edge mode, Border select is kind of working when zoom out


But get it back to normal view and you'll see some pattern instead of the whole mesh.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Thanks for the report. We are aware of this limitation and it's on the to do list. The only solution for it is to do a major rewrite of the selection code since it currently relies on what is drawn in the viewport, and anything that is smaller than a pixel can get lost. Maybe for Blender 2.8 this will be improved, for now this is not considered a bug.